Securty and setup warns

Hello Everyone!

How can i fix these warnings specially deafult phone region. What exactly i need to insert in config.php`?
What about other errors??

  • Your web server is not properly set up to resolve “/.well-known/webfinger”. Further information can be found in the documentation.
  • Your web server is not properly set up to resolve “/.well-known/nodeinfo”. Further information can be found in the documentation.
  • Your installation has no default phone region set. This is required to validate phone numbers in the profile settings without a country code. To allow numbers without a country code, please add “default_phone_region” with the respective ISO 3166-1 code :arrow_upper_right: of the region to your config file.

Can anyone help me out . I am new to Nextcloud

Thank you

The first two errors:

Just AllowOverride All in /etc/apache/apache.conf and the caldav redirect errors should go away.

Perhaps you must set it at a different place.

See post 52: Unavoidable security & setup warnings with NC 21 update - #52 by sleepbuild

Last error:

eg:
‘default_phone_region’ => ‘GB’,

https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/config_sample_php_parameters.html

Hello. The last error is solved. Thank you for that. Can you clearme about first two errors. I am attaching the file. What should i do here

The following 2 rules are only needed for the user_webfinger app.

# Uncomment it if you're planning to use this app.
#rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
#rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json
# last;

That depends on the webserver and the OS you are using, and whether you are running Nextcloud behind a reverse proxy or not.

If you are using Apache just make sure .htaccess is enabled. In Debian/Ubuntu open the file /etc/apache2/apache2.conf. Find the section <Directory /var/www/> and change the directive AllowOverride None to AllowOverride All. In addition to that you can also set it seperatly per VirtualHost. An example configuration for an Apache VirtualHost can be found here…

https://docs.nextcloud.com/server/stable/admin_manual/installation/source_installation.html#apache-web-server-configuration

After you made the changes, restart apache and upgrade the .htacces file of your Nextcloud installation:

sudo -u www-data php /path/to/nextcloud/occ maintenance:update:htaccess

For NGINX and/or Reverse Proxy configurations see…

https://docs.nextcloud.com/server/stable/admin_manual/installation/nginx.html

and

https://docs.nextcloud.com/server/stable/admin_manual/configuration_server/reverse_proxy_configuration.html

Hope that helps…

Thank you for your message.
i am using nginx and what command do i need to insert for these warnings second to which lines??

I’m not an expert when it comes to nginx. But I found this…

Hello! How to find out if it is working on Reverse Proxy or nginx?

Sorry for the late reply… Hope you solved the issue in the meantime.

By testing it…? Sorry as I said in a previous post. I’m not an expert when it comes to nginx and can therfore not give you detailed instructions.