Security scan: NOT on latest patch level for 22.1.0.1

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 22.1.01
Operating system and version (eg, Ubuntu 20.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.29
PHP version (eg, 7.4): 7.4.21

The issue you are facing:

Eventhough my installation is running the latest stable version 22.1.0.1, https://scan.nextcloud.com reports:

Running Nextcloud 22.1.0.1
NOT on latest patch level

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Install Nextcloud with version 22.1.0.1on a public server
  2. Use https://scan.nextcloud.com to scan it

The output of your Nextcloud log in Admin > Logging:

(not relevant for the problem)

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

(not relevant for the problem)

The output of your Apache/nginx/system log in /var/log/____:

(not relevant for the problem)

After pressing the Scan button, have reloaded the page in the browser? It is a well known that users are expecting to get the latest version displayed instantly after pressing the scan button but this is not the case. You always have to reload/refresh the web page to get the latest information displayed :wink:

1 Like

The displayed version is correct - that is not the problem. The problem is, that version 22.1.0.1 is considered as “NOT on latest patch level” - and this is not correct - 22.1.0.1 is the latest patch level at the moment. There is no newer version as of 2021-08-13. That is the version you also get when downloading Nextcloud from https://download.nextcloud.com/server/releases/. There is nothing newer than 22.1.0.1.

And yes - I did reload the page and I also tried “trigger rescan” and tested again - the result did not change.

1 Like

Blockzitat
I fully support @awelzel 's statements so far. The same happens to me:
NOT on latest patch level

Obviously the security scanner has not been updated yet and does not recognize the latest version. The rest of the tests should still be accurate. @awelzel already opend an issue on GitHub

1 Like