Secure Outlook add-in is now available for testing in free-as-in-beer version


#42

Ich habe keine Interesse


#43

@basildane the test version is for 32 bits. That is why it doesn’t work / show up. Somewhere next week I will release a newer version with a 64 bits installer.


#44

Cool, most of my Outlooks are 32 bit. But I have a few friends who use 64.
I used the plugin today! It’s very useful.


#45

I’m trying to test this add-in with Outlook 2013. My NextCloud server is on an alternate port (40443), and using a self-signed certificate. When I start Outlook, the dialog pops up for credentials, and I enter the url in the form https://my.server.com:40443, the same as works in a web browser, and a valid username and password. I get the error message “The settings are incorrect. Please check the server url, username and password.”

Since the credentials are correct, I’m wondering what’s going wrong here? Does the add-in not allow for a port to be specified in that way (or at all)? Does it have a problem with the self-signed certificate?


#46

Hi,

I discovered a problem with TLS higher than v1.0 when I received the same error message like you do.
It could be a different problem for you, but it is definitely nice to know that HTTPS with TLSv1.1 and TLSv1.2 only doesn’t work currently. Only if your server allows TLSv1.0 (and probably SSLv1 - v3) a connection can be established successfully.

The developer is informed and is working on supporting TLSv1.2 as well.

I’m not 100% sure about the port, but I guess another port shouldn’t be a problem.


#47

I have no problem with a custom port and a certificate from a trusted CA. Maybe you could try to add the cert/CA to the trusted store in Windows?


#48

Thanks, but I did already add the cert to the trusted store, this was done before my report above. I could try a certificate from a proper CA instead of the NextCloud-generated self-signed one, but I was hoping for some guidance as to whether that is actually likely to be the problem. It’s a shame the error message isn’t more informative. Maybe I’ll give it a try, if I can figure out how to import a certificate into a snap install of NextCloud.


#49

Having the same issues as @klorydryk. Running the revised version of the 32 bit add-in on Outlook 2010 32 bits (build 14.0.7184.5000) on Windows 10 Pro 64 bits (build 15063.483).

@klorydryk, did you manage to get the file sharing to work ?


#50

HI All,

I also installed the add-in with Outlook 2016 32bit and I can see now two icons in the menu bar when composing new e-mail (Upload for files and public sharing of folders).

In my NC I see the folder “Outlook” with subfolders “Public-Share” and “Upload-Files”.

BUT

From the Outlook Add-on Settings:

  • I am connected successfully to my NC
  • The button “Advanced” doesn’t work

From a new mail windows:

  • No content inside the e-mail
  • No actions when I click on buttons “Share Files” and “Share Public Folder”

Hope you can help me in understanding why it doesn’t work as expected.

Thank you very much.
User


#51

My understanding is that advanced functionality is NOT available on the ‘free as I’m beer’ version.

When you click on the public folder button a share is created on your NC folder inside a newly created ‘Outlook’ folder…

D


#52

Here’s a updated version of the add-in, I also compiled the 64 bits version now.

@User_loris do the other windows, like file uploading work and such? In the free edition the advanced options aren’t that necessary, you can only change the language and enable the debug mode.

When you upload a file or so it should be automatically inserted in your e-mail.


#53

@usselite
i waited for the new version and installed it (only after i de-installed the older version)… since i’m running oulook 2010 (32) on a win 7 (64) machine, i chose the 32-bit-version. hope that was ok.

so now… i can upload things. and i can see the title of the file after clicking on the link. but the file is 0kb (which isn’t correct)
plus: it still is ending up in a subfolder with some strange xyz1234abc987-letters. that could be irritating on the long run. isnt there another solution?

cheers - anyway i still the the add-on ^^
jim


#54

@JimmyKater
Yes, the 32 or 64 bits refers to Office 32 or 64 bits, not to Windows 32 or 64 bits.

Could you contact me and share perhaps some details about your Nextcloud server installation? I was under the impression this 0kb thing would be fixed.

The sub folders are not configurable yet. The strange letters is to guarantee an unique share folder. I thought about using the subject from the email but that’s not always an option. Would you have an other suggestion perhaps? :slight_smile:

Thanks!


#55

I installed the latest version and it works like a charm.
I have only one problem. My (ldap-)username contains a “umlaut” (ö).
When i try to login at the start of outlook, i got an error message “The settings are incorrect. Please check the server url, username and password.”.
Without the “umlaut” i can login and use the add-in with a problem.

Thanks and have a nice weekend.


#56

Hi All

Installed today… Excellent… No issues.

Thanks for fixing the spelling ‘Therefore’

Great work

Del


#57

Hi All,

I have installed the latest x86 version but it doesn’t work as expected.

Probably I have not understood how to use it, but when I click on the button “Share Files” nothing is happening (no windows, no menu) and no attached file are uploaded to my NC.

Could you please kindly explain me what I have to do to make it work?

Thank you very much.
Loris


#58

Hi All,

Again, I have also reinstalled the x86 version and now the problem is that the login credential are not accepted, even if these are correct.

The current status is that the add-on is not connected to my NC.

My impressions? It seems that the free edition is quite unstable…

Any thoughts would be very welcome!
Thank you again.
Loris


#59

@User_loris when you install the add-in for the first time it will pop-up a window where you can enter your Nextcloud server details.

Once those credentials are accepted the buttons when composing a new / replying to an existing mail will work accordingly. Please make sure that the installed add-in version (x86/64) matches the Office installation.

In case it still doesn’t work, send me a PM with some details of your server installation (kind of host/port/self-signed certificate/nc server version and such…) Thanks!

@Schroepel I will take a look at it, thank you for reporting!


#60

what about using addressees emailaddress as title of subfolder? even if there’s none you could force a “unknown” as subfolders name.


#61

@usselite,
Thank you very much for your comment.

Please see here below some details about my current environment:

  • I have just updated to NC 12.0.2 but it doesn’t work also with this latest build.
  • I have installed the x86 add-in version that matches the Office version.
  • I see the button “Share files” when composing a new message or replying to an email, but nothing is happening when I click on it.
  • Sometime the button “Share files” doesn’t happear (I have to close the message window and re-open it).
  • I have enabled HTTPS with EFF’s Certbot, deploying Let’s Encrypt certificates.
  • The connection from the add-in to my NC works fine (it says sucessfully connected).

Please let me know if I can send you some log files or screenshots that can help you in the troubleshooting.

Thank you again for your help.
Omar