Secure Outlook add-in is now available for testing in free-as-in-beer version

Yep that is the latest version! Does your Nextcloud login name contain any ‘special’ characters e.g. umlaut, spaces or whatsoever? What you can try to do is enable the logging in the registry (make sure Outlook is disabled) this would be ‘DebugMode=true’. Then start Outlook, try to connect through the settings dialog a few times. The log can be found in your my documents folder as yyyyMMdd_nextcloud_outlook.log. Can you PM me the log then? :slight_smile:

For the 64 bits version… strange, are you sure 64 bits Office is installed?

Because it sounds that the 64 bits registration is failing, whilst the 32 bits works.


omg! thanks for being that up. i didn’t notice that O2019 installed itself in a 32-bit version automatically. i need to change that. and then i’ll go on investigating

btw: 32bit version not connecting, though. but that’s not important right now.

thank you very much so far. will get back to you after changing from 32 to 64 outlook. which might take a while as i’ll be out until tmrw afternoon

Ah! Yes… Microsoft per default installs the 32 bit version. Btw, you are not installing the Microsoft Store Office version right???

1 Like

ummm. how would i know that? at least i paid for an outlook 2019 version by some provider.

Well, easiest way on figuring out if you are installing the Office 2019 from the Microsoft Store is if you have to download it through the actual Microsoft Store (app on Windows 10 pc’s)

The other version is usually downloaded from / But in case it is from a provider I am pretty sure you did not use the Microsoft Store to get your Office :slight_smile:

1 Like


changed to (64) and everything seems to work fine now… thanks so much!


Even problematic from my side, I can not connect to the Add in.
I can see my login page NC, write the right information, but in the end … there is error.

After my login i receive this screen (i grant the access):

And finally got this warning:

I read the majority of posts, but I have not found any solution …


Can you try to enable debugging? You can archieve this by navigating to your registry (regedit) to:
Computer\HKEY_CURRENT_USER\Software\NextcloudOutlookFE, then once you are there change ‘DebugMode’ to ‘true’. Either start or restart Outlook. Then try to login a few times. The log will be located in your my documents folder under yyyyMMdd_nextcloud_outlook.log.

Afterwards you can send me a PM with the log.

Some things that come to mind:

  • Self-signed certificates?
  • There’s a mention of a connection delay at the login dialog. This is due brute force protection. Now if prior login attempts went wrong it may delay api calls. That can cause a time-out depending on the delay. You can try whitelisting your IP with the brute-force app.
  • Does your username contain any special characters by any chance?

Thank for your help!
It was the “bruteforce” delay… so i added the bruteforce whitelist ip, and the NC add in work well!
Just a pity that we can not customize as the version offered to enterprises …
Do you know if there is a way to put in French the messages of this add-in instead of translating them manually each time?

Besides the addin language it is not possible to translate the HTML snippets without the enterprise version.

yup…and not available for enterprise under 50 seats…
and the french language is missing inside the cab1.
We have only eng, de, it, nl.

I have to check, but there is a partial French translation. Actually translating the add-in to any locale is possible by adding a new language file in C:\Program Files\Nextcloud Outlook\Resources\Translations. E.g. copy the English one, rename it to ‘fr.json’ and then modify it to your desire (values).

Here’s a partial translation to French. As you see there are some values missing.

Yup this is exactly what i have do yesterday.
Unfortunately everything remain in english.
fr-translation files

Are you certain? Try restarting Outlook, your language file seems to work at my installation, it is automatically detected.

yup finally its good for the french version.
But since i added the fr.json, when i click on public sharing or upload file, nothing appear in outlook after.
No box with link, password, etc

Yup unfortunately…
We cannot put a password or use the link we want, we are limited to date expiration.
It’s sad because the add-in seems interesting. But is not suitable for small structures (freelancer, SME).
Because the small players would also like to be able to personalize this html to arrange the whole with their images. At $ 5 … I would buy it right now for me. But … 50x $ 5 + hosting. Ouchie!
I will continue to share files and links myself by generating them myself.
Will certainly be less visually pleasing, but in the end … it’s only a link sharing.

Personally, i think they can bring a solution for freelancer and SME under 50 seats (if they host their own server).

We only need a maximum of 20 seats. At 5 € purchase price once we would immediately use the paid version. But 5 € a year is too much for us.

I am with you on this and I asked about it a long time ago to make it more affordable for smaller entities. Sadly nothing changed until today. A self-service only subscription plan that is really cheap but without any support (but gives access to enterprise features) would be a way to archive that and Nextcloud even earn some money without much effort (except payment processing probably).

1 Like

Hi there,
Thanks for the app. I am trying to use the free version(64bit) on Office 365 MSO (16.0.12325.20280) 64bit and am unable to attach a file. The option to create a Public Share is working, but I am unable to attache a file.
I am able to select upload files, which calls up the “Add files to email” dialogue. After selecting a file there is an error as shown on the image:

Are there any ideas what is going wrong? I have tested enabling macros and it still does not work.

Any help is much appreciated!

We recently tested the free version of the Outlook add-in and did not encounter this. Both uploading files and creating a public share was working. It may have something to do with your PHP upload and post limits. Can you check your upload_max_size as displayed in the Settings > Administration > System and whether the file you are trying to upload exceeds that?

Also check the following values in php.ini on your server
memory_limit >= 512M
post_max_size >= 4G
max_execution_time >= 300

post_max_size should also be >= to upload_max_size

And to rule out the obvious, check the quota of the user account versus its storage usage. :grinning:

1 Like