Secure Outlook add-in is now available for testing in free-as-in-beer version


#204

Well,

that’s great to hear and thank you very much for the quick response. Would be great to have that bug solved in the free edition as well.


#205

@usselite : I’ve installed the plugin Version 2301 on 3 PC running Outlook 2010. It worked on all three for 3 month now. Today I wanted to change the Nextcloud account used on one of the PC’s. This failed and since then all logins fail. I tried to log into a different server which fails on this machine but does not fail on another machine. I’ve removed the plugin from the machine and reinstalled it which did not help.
I can see a failed login on the server side but checked the credentials again and again. What else could cause this?
Thanks
codec


#206

@codec After restarting Outlook I need to enter my password which doesn’t work. Website login works with this credentials. Weired

update: today everything is fully functional again.


#207

@codec @Ben_Trask This migh be caused by the brute-force protection. If you whitelist your IP using this: https://apps.nextcloud.com/apps/bruteforcesettings the problem might be resolved, as what happens is the delay caused by the protection makes the add-in time-out and therefor fails to authenticate. If this doesn’t help let me know :slight_smile: In case for the machine that fails, you can try to remove the registry if the PC is in the same network. (regedit > Computer\HKEY_CURRENT_USER\Software\NextcloudOutlook)


#208

@usselite the brute-force protection wasn’t activated on the server. I’ve now activated it and whitelisted the IP of the gateway, so this should be safe now.
Actually I’ve already removed the registry keys of …\NextcloudOutlook with no success. I’ve even uninstalled the software, removed the registry keys and the installtion folders and reinstalled from a fresh download… same result… :frowning:
Any more ideas???
Thanks codec


#209

@codec hmm… do the Windows or Office version differ? - Do you use 2FA or something? Can you try a app password?


#210

Sorry for the late reply. It must have had something to do with the brute force tool. I’ve whitelisted all IP of my provider, then could login in. After that I removed the whitelist and all was fine again… :frowning:

Thanks
Codec


#211

Now I did a test against an IMAP Server using an Outlook 2010 and 2013.
When using the IMAP Server, the mail will get a “winmail.dat” attachment and the nextcloud blue box will not show, instead it looks like this:
grafik
Manually adding a link will be ok, as long as you do not use the Nextcloud button. If the button is used, all links will look like this.
Using an Exchange Server does not cause these Problems.

I tried to use RichText as Document-Format, which was no help. What else could I try??
Thanks
Codec


#212

It looks like a Outlook client related issue. Does this work? https://www.inmotionhosting.com/support/email/outlook/prevent-winmaildat