Secure Outlook add-in is now available for testing in free-as-in-beer version


#183

I guess I found the cause. I tried to install the beta version you released a few days ago. This version is causing the problem. Now I’ve uninstalled the beta, installed the regular version released in 10/2017, then installed the beta version after that. That’s working now.
Regards


#184

A new official build was released and uploaded. You may find it here. It is a stable 2.3.0.1.
https://download.nextcloud.com/outlook/20180705/

Besides the build what was published here some bug fixes where made.

@codec unfortunately the Office 2007 thing is not solved yet.


#185

first of all: great addin!
I’ve tried it today and was almost pleased. Almost, because there are some minor glitches that prevent me to use it. I hope they can be fixed someday.

a) (very minor), the box containing the link and the pwd into the mail is always in english. It should be localized too I think
b) (very important) To transfer files the addin uses the (automatically created) folder /Outlook. This cannot work here because the users have not quota in their home directories (sounds strange, but is a result because my nextcloud server is a VM only, containing no HD space. The Homedirs are CIFS mounts from a windows file server, appearing as a subfolder of the the Nextcloud homedir. Too complicated to be explained here, it has to do with CIFS, ACLs and parallel Usage from Windows and so on. For this addon it means, it cannot write anything into /Outlook, the path has to be configurable somewhere (in my case “/eigene Dateien/Outlook” would be possible)
It would be very nice if the path would become adjustable within the addon

(BTW: the test showed up another bug within Nextcloud too. The addin is able to create subfolders like /Outlook and so on, even without any quota. It fails ony later on when trying to transfer files. But it leaves behind a lot of empty folders. Obviously the quota check is not applied during the subfolder creation too.


#186

Hello @trillian59,

Thank you!

A) I will look into it.
B) There is an issue in the current build with getting quotas from external shares. It will be solved in the new build. Right now you can reconfigure the current path under (edit registry): ‘Computer\HKEY_CURRENT_USER\Software\NextcloudOutlookFE’ and modify ‘/Outlook/Upload-Files/’ as you see fit. Please make it starts and ends with a ‘/’. A lot of settings can be configured through the registry.

The quota check is only trigged at opening the ‘upload files’ and ‘public share’ dialog. Folder creation as; /Outlook/Upload-Files/(should stop here) is done at add-in start.

Let me know if you need more help :slight_smile:


#187

tnx for the quick reply, I have edited the registry as you have pointed out, but sadly, now the box is not inserted into the mail at all anymore.
Subfolders are created as expected, but no files are uploaded. Does the addon rely on a certain feature/addon included/enabled with nextcloud?

Also, I think there is a bit of misunderstanding about the quotas here (standard excuse: “english is not my natural language”): I dont have any problems with the “external” (mounted via CIFS) quota, but I have limited the normal “homedir” of the users to 0 Bytes.
I did this because I was unable to mount the /var/www/html/nextcloud/data directory either via CIFS or with NFS. I alway ran into problems with either name mappings or ACLs and so on.
So I denied write access to that dir and instead do an automatic CIFS mount to “/eigene Dateien” with the credentials of every user that logs on (users are taken from Windows AD).
Therefor the users are unable to create a Folder /Outlook. This works from the Webinterface or with the normal Nextcloud Desktop client. But your addon still is capable to create directories there, so there must be a missing quota check somewhere…

Anyway, I first have to focus to upload files at all and getting back the box with the links and password in the mail.
I have turned on debug log, now I have to search for it :slight_smile:

Update: the missing quota check is not your fault. I can reproduce the same error within pure nextcloud. You can create Directories as you much and as deep as you want, but if you try to fill them with files, the system tells you that there is no space left
So I will have to put this on on a different buglist


#188

Additional Tests restored the “put in the box” function again :slight_smile:
Although you can configure it, the path NEEDS to be “/outlook”, else the box does not appear anymore. There must be a forgotten check somewhere in the source, pls check it out.

For now I have managed to overcome this by adding a new global CIFS share named “/outlook” and writable for everybody.

Now the appropriate folders are created on startup, and files are transfered into them too. The generated links/pwds work too.
I did not check what happens if a second user does the same. Maybe paths collide, I will then have to make this share personal, automatically generating subfolders for every user like with the homedir. No big deal,

But again, the key to it all is to use the given Path “/Outlook/” (and not touching the registry at all)

hmm, i just wonder if the real problem could not be “path too long” too ?!!?!?
Takeing your “/Outlook/Upload-Files/YYYYMMDD/VERYLONGRANDOMFOLDER/” and adding some filenames too might still work, but adding my “/eigene Dateien” on top might lead to a filename that is too long for CIFS access…


#189

Hello @trillian59

I checked the source code for any missing of “/outlook”, however that was not the case. Are you running version 2.3.0.1, available to download from the Nextcloud website? I recommend restarting Outlook when you change the paths. Also it looks like you use the add-in within an organization, the effects of the registry item you modify are only for the current user.

Currently we are working on version 2.3.1, this version will allow you to disable the ‘date’ path plus set a manual name.


#190

“Organization” is a bit overdone :slight_smile: This is just a LAN/WLAN connecting some neighbors which use central servers together. But of course, there is an AD, some (alot of) GPOs and all that stuff you would find in a company too.
Yeah, I am aware of the “current user” stuff and am already thinking about it because I am planning to roll out the addon without annoying unaware users like kids and so on.
No deal to run the setup from a already existing software GPO, although your MSI does not really do anything when called with the /quiet option (add this to your bug list please), but /passive works well, this will have to do then.
And yes, I’ve noticed the setup alone does not do anything to the registry, So here is another question for you:
Does the addon honor a template in the registry?
It is quite common for applications to look at HKEY_CURRENT_USER … and, when there is nothing (first startup), take a look at HKEY_USERS/.default/… . If they find their path/entries here, they copy them over to HKEY_CURRENT_USER and start with these values. (I could surely find the needed code in old sources if you dont want to type yourself (C/C++ only))

This is quite easy to implement, maybe you have done it already?
If not, consider giving it a try.
(there is not much to preconfigure, but of course the servername, the path and maybe the username too (unless you fill in the default altready with the login name of the current user). So the only thing they would really need to fill in is their password and they will be done with it.)

Maybe my guess with the missing /outlook was really bad and wrong and the “path too long” problem really showed up. Being the only user here currently gives me the chance to test it out today without disturbing anybody. But still I did not find the “debug log”, maybe it could tell me what went wrong when files and boxes do not appear ?
Or do I need to use a machine with visual Studio (Debugger installed) ?


#191

I think the /quiet option you are looking for is /qb (INSTALLFOLDER is optional):
msiexec /i "<location msi>" INSTALLFOLDER="<location install directory>" /qb
msiexec /i "C:\example\Setup_x64.msi" INSTALLFOLDER="C:\Users\Luc Pasmans\My Documents\addin" /qb

The add-in once initialized creates the registry entries in the current user (so Outlook, plus the add-in has to start). Unfortunately it does not use the HKEY_USERS/.default/… You can however automate the import of some registry keys e.g. with powershell.
You don’t need to visual studio debugger. If you enable logging under advanced settings, restart Outlook and then do some actions you may find the debug file in the ‘documents’ folder of the current user (e.g. C:/Users/Luc Pasmans/My Documents/) under yyyyMMdd_nextcloud_outlook.log.

When you mention the box(es), do you mean the upload file dialog then??


#192

no, i mean the blue box with the nextcloud logo, the link and the password that is inserted into the mail if you add files to the upload filed dialog and close it with “ok” then.

It does not appear anymore if the path is “not good” (as we still not know what “good” means, this is just a phrase, dont take it literal!).

This can either be a fault, or just a side effect because the addon was unable to upload the files. There is no error message somewhere (on the screen) so it looks to the user as if NOTHING had happened at all.

tnx for pointing out the log, it revealed its secret:

404
** You are not allowed to share /mam/files/eigene Dateien/Outlook/Upload-Files/20180827/5bbbdf597c1446038eee728859019797**

so no wrong path or “path too long”, just a “mam too stupid” error :slight_smile:

But, you may consider to present the error within a messagebox to the user. Its hard to guess what went wrong if you have not the slightest idea (yeah, I have disabled sharing here in general to prevent people offering stuff the world should not see :slight_smile: )

(the log contains a lot of personal data, if you want it, send me your email, its not good to be posted here)


#193

Hmm, here it went into “C:\Program Files\Nextcloud Outlook” (aka %PROGRAMFILES%) which is perfecty fine because many machines are used by multiple users (aka “family members” :slight_smile: )
Maybe I do have a permission problem, or ULC shit… I will check it out later. For now /qn does not do anything over here (/quiet and /qn are eqivalents, /passive is the equivalent to /qb. Checkitout with “msiexec /?” you get a dialog with the possible options)

(in general, /qn shows NOTHING, /qb opens a window with a progressbar, but no user interaction possible. /qf shows the full setupdialog, as if you would not have given any option)


#194

yeah, further tests showed that is was purely my fault. I have to enable “allow sharing” for the path that you use for uploading the transit files. This is logical. So I will stay with my seperate share for “/outlook” because I can turn this on and off on a per-share base.

The /qn setup problem could be locked down to Windows10 Administrator mode. It WORKS, but only when run by the SYSTEM account or “TrustedInstaller”. Again its a bit bad that no error message pops up when it fails because it was started by the wrong user. A little bit of “Permission denied” or something could help.

The “advanced settings” page rises some more question for me, I guess, I will bother you with them :slight_smile:
a) I think you know that many localizations (including dutch) dont really fit and are cut off at the end?
b) there is not much to do there, most fields are grey. For me, only the “Debug” button is workable for now. The password button does not even exist (empty field)
c) the two HTLM Boxes are grey too, I guess one could copy that code and insert it into a message? This does not work of course because you cannot use Cut&Paste on a disabled box.
d) even if you could, the code in there is made with “generator word”, it contains tons of Microsoft CSS Code one usally does not want to sent into the world. If these are the “blue boxes” with the links and passwords, you could “optimize” and cut down the code to a few lines only giving the same optical results and avoiding gigantic styles downloads (i cant make it out for now, the shown part (not scrollable) does not really do anything for now, there are a lot of lines “missing” yet)


#195

I have an issue with the add-in. I recently had issues connecting to my Nextcloud instance and at this time it turned out, that everytime I start my Outlook without connection to Nextcloud, the add-in pops-up and asks for the password. Even when I restart outlook after such an incident, the add-in comes up and ask for the password. It’s just like the add-in forgets the password at a restart without connection. That should not be.

It’s even more annoying as the pop-up blocks Outlook from starting further until either a valid password has been entered or the dialogue is manually closed.

P.S.: I really do love the customized default upload folders and the activity features. I have only tested the first so far, but this seems to work like a charm. Any change you can integrate that into setting, so one doesn’t have to manually change the Registry?


#197

Hello @RiSK you might want to whitelist your own IP from brute-force protection (if your nextcloud is hosted somewhere). This could solve the issue where the add-in will try to login on startup each time.
https://apps.nextcloud.com/apps/bruteforcesettings

Let me know if it works,


#198

Great plugin but there is one big issue: I see no possibility to use App-Password instead of username/password. For me, App-Password is very important. Could it be integrated into this Plugin?


#199

I used > Username/ app-password successfully < already. What doesn’t work for you exactly?
I remember cases that were reported in this forum, about problems with app passwords after an NC update. Could you check that app passwords work in general on your server and that the app password for your Outlook plugin was created in a time-frame around the app password, that currently works (just to make sure there is no update related issue with app passwords)?


#200

I don’t know the reason, but with the third try, it worked!


#201

I don’t know if it’s a bug but if you try to upload files with a long name they don’t appear in the upload dialog (the list below the Select files to upload button) even though they got uploaded when you hit the Upload files button. I tried this on two different PCs (both Win7 x64, Outlook 2010 x86, latest Version of the outlook plugin)


#202

I forgot to say that it seems only to affect xml files


#203

Hello @Ben_Trask that is due a mime - mapping error (match to the appropiate image), right now I don’t have the time to merge the enterprise edition with the free edition but that particular error should be solved :slight_smile:

I’ll do my best to update the free-edition as soon as possible again.