Secure Outlook add-in is now available for testing in free-as-in-beer version

Yup unfortunately…
We cannot put a password or use the link we want, we are limited to date expiration.
It’s sad because the add-in seems interesting. But is not suitable for small structures (freelancer, SME).
Because the small players would also like to be able to personalize this html to arrange the whole with their images. At $ 5 … I would buy it right now for me. But … 50x $ 5 + hosting. Ouchie!
I will continue to share files and links myself by generating them myself.
Will certainly be less visually pleasing, but in the end … it’s only a link sharing.

Personally, i think they can bring a solution for freelancer and SME under 50 seats (if they host their own server).

We only need a maximum of 20 seats. At 5 € purchase price once we would immediately use the paid version. But 5 € a year is too much for us.

I am with you on this and I asked about it a long time ago to make it more affordable for smaller entities. Sadly nothing changed until today. A self-service only subscription plan that is really cheap but without any support (but gives access to enterprise features) would be a way to archive that and Nextcloud even earn some money without much effort (except payment processing probably).

1 Like

Hi there,
Thanks for the app. I am trying to use the free version(64bit) on Office 365 MSO (16.0.12325.20280) 64bit and am unable to attach a file. The option to create a Public Share is working, but I am unable to attache a file.
I am able to select upload files, which calls up the “Add files to email” dialogue. After selecting a file there is an error as shown on the image:

Are there any ideas what is going wrong? I have tested enabling macros and it still does not work.

Any help is much appreciated!

We recently tested the free version of the Outlook add-in and did not encounter this. Both uploading files and creating a public share was working. It may have something to do with your PHP upload and post limits. Can you check your upload_max_size as displayed in the Settings > Administration > System and whether the file you are trying to upload exceeds that?

Also check the following values in php.ini on your server
memory_limit >= 512M
post_max_size >= 4G
max_execution_time >= 300

post_max_size should also be >= to upload_max_size

And to rule out the obvious, check the quota of the user account versus its storage usage. :grinning:

1 Like

Hi @TheThunder777 ,

Like @autoize mentioned this most likely relates to the quota. Also external drives may push something else. It may also be possible in case theres a LDAP back-end the userid differs from the username. I do think it was solved though in the latest available free-edition builds. In the registry therefor there should be a userid.

I will look into providing a new build this weekend.

Thankyou both.

I have implemented the settings as suggested and still have the same error, although I seem only able to get a memory_limit of 256 despite editing the php.ini. I am thinking it is possibly an issue with my server hosting, unfortunately.

Forgive my ignorance but I am not sure what an LDAP backend is. I will await the new release in the hopes that it resolves the issue ( thankyou ). And if it does not I guess I will need to adopt different hosting.

I appreciate your responses.


1 Like


I had same problem with connect to my nextcloud server

Or I see error " The settings are incorrect. Please check tehe server url, username and password"

Brute force protection configured
We use trusted certificate for installation
We use simple user name

Hi @_Dmitrij,

Can you enable logging? Through the registry:

Then enable ‘DebugMode’ to true. Restart Outlook.

Try to connect a few times, log will be placed in your my documents folder.

You can PM me the log.

oopps… no new version there anymore?? :frowning:

Yes, very sad, I would need the new version because the old one stopped working with NC 18 here.
Is there another place to look for the new version?


I grabbed a copy when they were first posted (x86 and x64 versions)

1 Like

Strange. Looks like the link got broken for some reason. Here is a new one.

1 Like

Hey nextclouders,

I have an interesting issue.
The plugin uses the subject field for creating the shared folder in nextcloud.

Everytime one of our users try to upload something to an Forward or Reply -Mail the plugin stops working because nextcloud can’t create folders with a special character in it.

Forward mails contain "FW: " where the “:” is the problem. (Same for reply - RE:)

So I guess it’s a bug?! Can anyone of you confirm that this is a really issue?

Just found out that the problem is related to our file system used for Nextcloud.
We’re using a Windows Server file share (NFS mounted) and windows does not accept “:” as valid characters in folder/file names.

Hi everyone,
I’ve updated to NC 18.0.3 on the server. Now the Outlook plugin stopped working. When trying to login it takes a while then says: “The settings are incorrect. Please check the Server URL, Username and Password” (translated from german).
I’ve done the update on a different server before without problems with the Add-In afterwards. Where should I start to dig into this.
The Login to NC with the username and password using firefox works with no problem. NC says there have been some unsuccessful login attempts from this IP, so it looks as if it doesn’t accept the username+password combination any more…


Can you enable debugging and PM me the log? This can be done through settings or the registry. Logs are written to your my documents directory. Please try a few times to login while debugging is on. (Computer\HKEY_CURRENT_USER\Software\NextcloudOutlook —> DebugMode=True and restart Outlook)

Also make sure you are running version, listed here in this topic.

I have the same error, is there any solution so far?

You can attempt to whiteliste your IP with the brute force settings app.