Search for user imported ssl-certs after update

Hi, I just updated from nextcloud 20.0.7 to Nextcloud 21 (docker). Everything seems fine, but I have to errors…one of them is yellow:

A background-job is running, that searches for user-imported ssl-certificates. Please try again later
The Module php-imagick is missing the svg-support

Both of them were not present on NC 21 and are not resolvable for me, as the ssl-warning persists for two hours now, and a manual run of the cron dosen’t do the trick…how can I resolve?

From the logs I discovered that this problem is related to the Talk-App…After disabling and enabling talk again, the warning is gone…

I see the same warning after upgrading to v21 but disabling and enabling Talk did not work for me. Can you explain how you found out that it was the Talk App in your case? Did you restart the container after disabling Talk?

Yes disable talk and restart container

I disabled it and restarted but the warning message is still there. Even uninstalling the Talk app completely did not resolve the situation. Do you have any other ideas what I could test?

1 Like

Do the logs give any hint? Try a reboot of the whole machine…

It seems in my case the jobs did not get started. After I changed from AJAX based cron to external/system cron, the message was gone.

3 Likes

Okay very nice! Glad it is resolved

1 Like

Alerte de securitate & configurare

It’s important for the security and performance of your instance that everything is configured correctly. To help you with that we are doing some automatic checks. Please see the linked documentation for more information.

There are some warnings regarding your setup.

  • A background job is pending that checks for user imported SSL certificates. Please check back later.

???
Nextcloud 21.0.0

3 Likes

I want to thank bf8392 for his solution as it worked well for me. I disabled Talk and any app referring to talk and checked overview again and I still got the warning. However, once I re-enabled Talk again and checked overview, all checks passed. Thanks, once more.

1 Like

No Problem :slight_smile:

Thanks this worked for me. :+1:

I don’t have Talk installed nor do I want to install it. How do I get rid of this error?

1 Like

Works for me, too. :slightly_smiling_face: