Search Extremely Slow

[/SCREENSHOT]

[/DETAILS]

Nextcloud version - 20.0.5
Operating system and version - Ubuntu 18.04
Apache or nginx version - Apache 2.4.29
PHP version - 7.4.14 (2GB Memory)
MySQL version - 5.7.32 (645MB Database)

The issue you are facing:
Searching for something on our Nextcloud server takes minimum 7 minutes for results to appear. Is there anything we can do to improve / fix this?

Is this the first time you’ve seen this error?
No - Noticed it for a while (possibly due to large instance)

Steps to replicate it:

  1. Click Search icon on toolbar
  2. search for an item
  3. …wait

ALL LOG FILES REDACTED (IP ADDRESS, USERNAME, FILENAME)

The output of your Nextcloud log in Admin > Logging:


TOO LARGE FOR POST

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'instanceid' => '## HIDDEN ##',
  'passwordsalt' => '## HIDDEN ##',
  'secret' => '## HIDDEN ##',
  'trusted_domains' => 
  array (
    0 => '## HIDDEN ##',
    1 => '## HIDDEN ##',
    2 => '## HIDDEN ##',
  ),
  'datadirectory' => '/mnt/data',
  'defaultapp' => 'files',
  'overwrite.cli.url' => '## HIDDEN ##',
  'dbtype' => 'mysql',
  'version' => '20.0.5.2',
  'dbname' => '## HIDDEN ##',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '## HIDDEN ##',
  'dbpassword' => '## HIDDEN ##',
  'installed' => true,
  'maintenance' => false,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis-server.sock',
    'port' => 0,
    'timeout' => 0.0,
  ),
  'knowledgebaseenabled' => false,
  'allow_user_to_change_display_name' => true,
  'skeletondirectory' => '',
  'filelocking.enabled' => true,
  'integrity.check.disabled' => true,
  'lost_password_link' => 'disabled',
  'htaccess.RewriteBase' => '/cloud',
  'activity_expire_days' => 30,
  'mail_smtpmode' => 'smtp',
  'mail_from_address' => '## HIDDEN ##',
  'mail_domain' => 'outlook.com',
  'mail_smtphost' => 'smtp.office365.com',
  'mail_smtpport' => '587',
  'mail_smtpsecure' => 'tls',
  'loglevel' => 2,
  'theme' => '',
  'updater.release.channel' => 'stable',
  'app_install_overwrite' => 
  array (
    0 => 'apporder',
    1 => 'calendar',
    2 => 'files_trackdownloads',
    3 => 'files_clipboard',
    4 => 'jsloader',
  ),
  'logtimezone' => 'Europe/London',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '## HIDDEN ##',
  'mail_smtppassword' => '## HIDDEN ##',
);

The output of your Apache/nginx/system log in /var/log/____:

[Sun Jan 17 00:08:16.541558 2021] [mpm_prefork:notice] [pid 2361] AH00163: Apache/2.4.29 (Ubuntu) OpenSSL/1.1.1i configured -- resuming normal operations
[Sun Jan 17 00:08:16.541634 2021] [core:notice] [pid 2361] AH00094: Command line: '/usr/sbin/apache2'
[Sun Jan 17 01:17:30.981435 2021] [php7:error] [pid 9292] [client ## HIDDEN ##:49503] script '/var/www/html/proxyjudge.php' not found or unable to stat
[Sun Jan 17 05:16:28.284355 2021] [php7:error] [pid 13404] [client ## HIDDEN ##:59852] script '/var/www/html/index.php' not found or unable to stat
[Sun Jan 17 10:10:44.668055 2021] [php7:error] [pid 27376] [client ## HIDDEN ##:46106] script '/var/www/html/index.php' not found or unable to stat


Additional Info:
Operating System: Linux 4.15.0-130-generic x86_64
CPU: Intel Xeon Processor (Skylake, IBRS) (4 cores)
Memory: 3.85 GB
Network Speed: 1 Gbps Duplex
Total users: 64

HDD Archtecture: SSD
Files: 1248476
Storages: 98
Free Space: 216.6 GB

1 Like

Can anyone help please?

Are you running into Files search takes a long time with unified search · Issue #23835 · nextcloud/server · GitHub ?