reports wrong NC version [solved]

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 14.0.4): 14.0.4
Operating system and version (eg, Raspberry image): Raspberry Image
Apache or nginx version (eg, Apache 2.4.): Apache 2.4
PHP version (eg, 7.2): 7.2

The issue you are facing: detects version 13.0.4

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

  2. enter hostname and port
  3. reported wrong version number

The output of your Nextcloud log in Admin > Logging:

No significant issues reported in log

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    5 => '.',
    1 => '192...',
    2 => '',
    7 => '',
    8 => '.',
  'datadirectory' => '/var/www/nextcloud/data',
  'overwrite.cli.url' => 'http://localhost/',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => '',
  'mysql.utf8mb4' => ,
  'dbuser' => '',
  'dbpassword' => '',
  'installed' => ,
  'instanceid' => '',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
    'password' => '=',
  'mail_smtpmode' => '',
  'mail_smtpauthtype' => '',
  'mail_from_address' => '',
  'mail_domain' =>
  'overwriteprotocol' => '',
  'loglevel' => '',
  'log_type' => 'file',
  'maintenance' => false,
  'mail_smtpsecure' => 
  'mail_smtpauth' => 
  'mail_smtphost' => 
  'mail_smtpport' =>
  'mail_smtpname' => '
  'mail_smtppassword' =>
  'theme' => '',
  '' => 'production',

The output of your Apache/nginx/system log in /var/log/____:


Hi, does anyone have any sugegstion ?
Upgraded to 14.0.6, but still showes 13.04

Usually it shows the date of the last scan. Have you pressed the rescan button? After that, wait some minutes and reload the page.

1 Like

Thanks for reply !
Not the desired results, however.

Upgraded to 15.0.2 without errors.
Setting and Systeminfo show that correctly.

Now reports:
Running Nextcloud
Latest patch level
Major version still supported

It seems to me the scanner is a version behind :slight_smile:
So the results improved, but it still is somewhat unsatisfactory.

I really like to know why. Where does the scanner get this info from ?

Did you read the answer carefully? :wink:
After you updated Nextcloud, on the scan website you need to press the retest button. It takes a while then until the retest is done. Reload the page after some minutes and carefully check the last check date/time if it is was updated definitely after Nextcloud update has finished.

Thanks, yes I did read it carefully :wink:, and waited a while to do a rescan. That showed the same at the time, as I mentioned

A few days later I scanned the site again, and it finally showed the proper version number.

So, it seems the issue is gone

Thanks for replies ! :smiley: