Samba wizard error

,

Hello everyone,

I have Nextcloud running on a Raspberry Pi 3.

[ nc-info ]
Gathering information...
NextCloudPi version  v0.53.5
NextCloudPi image    NextCloudPi_02-06-18
distribution         Raspbian GNU/Linux 9 \n \l
automount            yes
USB devices          sda 
datadir              /media/USBdrive/ncdata
data in SD           no
data filesystem      btrfs
data disk usage      2.8G/3.7T
rootfs usage         1.9G/29G
swapfile             /var/swap
Nextcloud check      ok
Nextcloud version    13.0.0.14
HTTPD service        up
PHP service          up
MariaDB service      up
Redis service        up
Postfix service      up
internet check       no }
port check 80        open
port check 443       open
IP                   192.168.1.104
gateway              192.168.1.1
interface            eth0
certificates         *****
certs due            82 days 
NAT loopback         no
uptime               8:12

You should enable dnsmasq to use your domain inside home

When I click Run on Samba wizard, the log shows:

[ samba ]
adding SAMBA share for user HTPC
adduser: Please enter a username matching the regular expression configured
via the NAME_REGEX configuration variable.  Use the `--force-badname'
option to relax this check or reconfigure NAME_REGEX.
Failed to add entry for user HTPC.
usermod: user 'HTPC' does not exist
adding SAMBA share for user ncp
SMB enabled

But I can’t log from Windows, I always get a Access denied message.

The samba.conf is:

 NextCloudPi automatically generated from here. Do not remove this comment

[ncp-HTPC]
    path = /media/USBdrive/ncdata/HTPC/files
    writeable = yes
;       browseable = yes
    valid users = HTPC
    force group = www-data
    create mask = 0770
    directory mask = 0771
    force create mode = 0660
    force directory mode = 0770

[ncp-ncp]
    path = /media/USBdrive/ncdata/ncp/files
    writeable = yes
;       browseable = yes
    valid users = ncp
    force group = www-data
    create mask = 0770
    directory mask = 0771
    force create mode = 0660
    force directory mode = 0770

What credentials I have to put in Windows login dialog box to connect?

Thank you.

PS: Sorry for my english :wink:

That looks like you’ll need to use the user ncp with the password you’ve configured for the ncp user.
If you haven’t set a password for that user yet, do so with sudo smbpasswd -a ncp

Thank you.
Samba is accesible, at least.

Another problem I discovered is the NAME_REGEX. It avoid the creation of users because I use capital letters…
I change the etc/ adduser.conf, but it seems the change doesn’t apply, even after reboot. And I need capital letters, because will be more easy that edit all user names I think.

Thanks for your report, I will modify the samba launcher so that if the user create fails the whole thing fails. I will also have a look at the NAME_REGEX issue

edit: implemented in v0.53.6