S3 storage, encryption issue

Hi everybody,

I am having trouble using s3 as external storage, with encryption enabled.

If I set up Amazon S3 external storage and provide all infos requested, with encryption disabled, everything works fine.
If I enable encryption, it only works with ‘Activate sharing’ option enabled.

But after a short period of time (a few minutes) I cannot open/rename/delete anymore the files I uploaded.
I can nevertheless upload other files, but with no possibility to open them any longer.

I tried everything I could so far. Any advice?

Thx, Laurentiu

The problem seems to have come from a user-policy in Amazon IAM configuration.

I tried to establish granular acces to objects/folders in the same bucket (user1 to folder1, user2 to folder2, etc) and the problems kept coming, and in NC I set up external storage to the same bucket for all users. I changed only keys required for login to AWS.

After changing this modus operandi, I created separate buckets for each IAM user and set up a bucket policy to let just user1 to accces bucket1, with full permisions. Back in NC I set up external storage for each bucket, with permissions for a certain group.

No problem so far.