Running Nextcloud behind NGINX Reverse Proxy

Hi guys,

I have a freshly installted Nextcloud instance on a VM with Ubuntu. The instance is behind a nginx reverse proxy on a lxc with debian. I can access the nextcloud via, I can add files… that works. But everytime I reload the site I get the “first welcome pop-up” and I’m not able to load any apps. I get 404 Not Found.

I have a headers.conf, a ssl.conf, HTTPGateway.conf and a xx.xxxx.xx.conf on my reverse proxy. Here is my xx.xxxx.xx.conf

server {
        listen 443 ssl http2;
        listen [::]:443 ssl http2;
        server_name xx.xxxx.xx;

        # SSL configuration
        # RSA certificates
        ssl_certificate /etc/letsencrypt/xx.xxxx.xx/rsa/fullchain.pem;
        ssl_certificate_key /etc/letsencrypt/xx.xxxx.xx/rsa/key.pem;
        # ECC certificates
        ssl_certificate /etc/letsencrypt/xx.xxxx.xx/ecc/fullchain.pem;
        ssl_certificate_key /etc/letsencrypt/xx.xxxx.xx/ecc/key.pem;

        # This should be ca.pem (certificate with the additional intermediate certificate)
        # See here:
        # ECC
        ssl_trusted_certificate /etc/letsencrypt/xx.xxxx.xx/ecc/ca.pem;

        # Include SSL configuration
        include /etc/nginx/snippets/ssl.conf;

        # Include headers
        include /etc/nginx/snippets/headers.conf;

        # Set the access log location
        access_log /var/log/nginx/xx.xxxx.xx.access.log;

location ~ \.* {
                proxy_read_timeout  90;
                proxy_redirect http://xx.xxxx.xx;
        # Make a regex exception for `/.well-known` so that clients can still
        # access it despite the existence of the regex rule
        # `location ~ /(\.|autotest|...)` which would otherwise handle requests
        # for `/.well-known`.
        location ^~ /.well-known {
                # The rules in this block are an adaptation of the rules
                # in `.htaccess` that concern `/.well-known`.

                location = /.well-known/carddav { return 301 /remote.php/dav/; }
                location = /.well-known/caldav  { return 301 /remote.php/dav/; }

                location /.well-known/acme-challenge    { try_files $uri $uri/ =404; }
                location /.well-known/pki-validation    { try_files $uri $uri/ =404; }

                # Let Nextcloud's API for `/.well-known` URIs handle all other
                # requests by passing them to the front-end controller.
                return 301 /index.php$request_uri;

My HTTPGateway.conf:

server {
    listen 80;
    listen [::]:80;
    server_name xx.xxxx.xx;

    root /var/www;

    location ^~ /.well-known/acme-challenge {
        default_type text/plain;
        root /var/www/letsencrypt;
        location ~ \.* {
                return 301 https://$host$request_uri;


My ssl.conf:

# Configure SSL

# Diffie-Hellman parameter for DHE ciphersuites, recommended 4096 bits
ssl_dhparam /etc/nginx/dhparams/dhparams.pem;

# Not using TLSv1 will break:
# Android <= 4.4.40 IE <= 10 IE mobile <=10
# Removing TLSv1.1 breaks nothing else!
ssl_protocols TLSv1.2 TLSv1.3;

# SSL ciphers: RSA + ECDSA
# Two certificate types (ECDSA, RSA) are needed.

# Use multiple curves.
ssl_ecdh_curve secp521r1:secp384r1;

# Server should determine the ciphers, not the client
ssl_prefer_server_ciphers on;

# SSL session handling
ssl_session_timeout 1d;
ssl_session_cache shared:SSL:50m;
ssl_session_tickets off;

# SSL stapling has to be done seperately, becuase it will not work with self signed certs
# OCSP Stapling fetch OCSP records from URL in ssl_certificate and cache them
ssl_stapling on;
ssl_stapling_verify on;

# DNS resolver

And my headers.conf:

# Add headers to serve security related headers
# HSTS (ngx_http_headers_module is required)
add_header Strict-Transport-Security "max-age=63072000; includeSubdomains; preload;" always;
add_header X-Content-Type-Options "nosniff" always;
add_header X-XSS-Protection "1; mode=block" always;
add_header X-Robots-Tag none always;
add_header X-Download-Options noopen always;
add_header X-Permitted-Cross-Domain-Policies none always;
add_header Referrer-Policy no-referrer always;
add_header X-Frame-Options "SAMEORIGIN" always;

# Remove X-Powered-By, which is an information leak
fastcgi_hide_header X-Powered-By;

#prox headers
proxy_set_header Host $host;
proxy_set_header X-Forwarded-Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto https;

On my Nextcloud instance I have just one file xx.xxxx.xx.conf:

upstream php-handler {
    server unix:/var/run/php/php7.4-fpm.sock;
server {
    listen 80;
    listen [::]:80;

        # Path to the root of your installation
        root /var/www/nextcloud;

        # Specify how to handle directories -- specifying `/index.php$request_uri`
        # here as the fallback means that Nginx always exhibits the desired behaviour
        # when a client requests a path that corresponds to a directory that exists
        # on the server. In particular, if that directory contains an index.php file,
        # that file is correctly served; if it doesn't, then the request is passed to
        # the front-end controller. This consistent behaviour means that we don't need
        # to specify custom rules for certain paths (e.g. images and other assets,
        # `/updater`, `/ocm-provider`, `/ocs-provider`), and thus
        # `try_files $uri $uri/ /index.php$request_uri`
        # always provides the desired behaviour.
        index index.php index.html /index.php$request_uri;

        # set max upload size and increase upload timeout:
        client_max_body_size 512M;
        client_body_timeout 300s;
        fastcgi_buffers 64 4K;

        # Enable gzip but do not remove ETag headers
        gzip on;
        gzip_vary on;
        gzip_comp_level 4;
        gzip_min_length 256;
        gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
        gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/ application/x-font-ttf application/x-web-app-manifest+json application/xhtml+xml application/xml font/opentype image/bmp image/svg+xml image/x-icon text/cache-manifest text/css text/plain text/vcard text/vnd.rim.location.xloc text/vtt text/x-component text/x-cross-domain-policy;
        # Rule borrowed from `.htaccess` to handle Microsoft DAV clients
        location = / {
                if ( $http_user_agent ~ ^DavClnt ) {
                        return 302 /remote.php/webdav/$is_args$args;

        location = /robots.txt {
                allow all;
                log_not_found off;
                access_log off;

        # Rules borrowed from `.htaccess` to hide certain paths from clients
        location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)(?:$|/)  { return 404; }
        location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console)                { return 404; }

        # Ensure this block, which passes PHP files to the PHP process, is above the blocks
        # which handle static assets (as seen below). If this block is not declared first,
        # then Nginx will encounter an infinite rewriting loop when it prepends `/index.php`
        # to the URI, resulting in a HTTP 500 error response.
        location ~ \.php(?:$|/) {
        # Required for legacy support
        rewrite ^/(?!index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy) /index.php$request_uri;

                fastcgi_split_path_info ^(.+?\.php)(/.*)$;
                set $path_info $fastcgi_path_info;

                try_files $fastcgi_script_name =404;

                include fastcgi_params;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                fastcgi_param PATH_INFO $path_info;
                fastcgi_param HTTPS on;

                fastcgi_param modHeadersAvailable true;         # Avoid sending the security headers twice
                fastcgi_param front_controller_active true;     # Enable pretty urls
                fastcgi_pass php-handler;

                fastcgi_intercept_errors on;
                fastcgi_request_buffering off;

                fastcgi_read_timeout 600;
                fastcgi_send_timeout 600;
                fastcgi_connect_timeout 600;

                fastcgi_param PHP_VALUE "upload_max_filesize = 10G
                        post_max_size = 10G
                        max_execution_time = 3600
                        output_buffering = off";

        location ~ \.(?:css|js|svg|gif|png|jpg|ico|wasm|tflite)$ {
        try_files $uri /index.php$request_uri;
        expires 6M;         # Cache-Control policy borrowed from `.htaccess`
        access_log off;     # Optional: Don't log access to assets

        location ~ \.wasm$ {
            default_type application/wasm;

        location ~ \.woff2?$ {
                try_files $uri /index.php$request_uri;
                expires 7d;         # Cache-Control policy borrowed from `.htaccess`
                access_log off;     # Optional: Don't log access to assets

        # Rule borrowed from `.htaccess`
        location /remote {
                return 301 /remote.php$request_uri;


In my config.php I have this added:

'trusted_proxies' => '',

Any Ideas why the nginx error.log says this:

2021/12/18 21:25:24 [error] 22832#22832: *15 open() "/var/www/nextcloud/apps/theming/styles" failed (2: No such file or directory), client:, server: xx.xxxx.xx, request: "GET /apps/theming/styles?v=0 HTTP/1.0", host: "xx.xxxx.xx"

It happens for all apps. I have no good clue. Is it because nextclouds awaits communication via https? Or is it because I mix http and https up accidently?

I’m happy for any help or suggestions.

Thank you a lot! :slight_smile: