Running nextcloud and collabora on the same host

Hi there,
I’ve succesfully installed and using nextcloud on my Debian based server, including TSL (using Let’s Encrypt certbot) and making it reachable from the outside of the LAN with a free dynamic DNS service (
Now I’d like to install the collabora code but I nedd to do it on the same host.
I’ve succesfully installed docker, pulled the collbora/code and started it, but I’m not able to properly configure the webserver (apache2).
Can someone help me on this?
Thank you in advance!

i wrote a simple howto, but atm there seems to be a little issue with the docker image (on my site at least).

but nonetheless, check out the post and please tell me/us if this worked for you!

Thank you victorbw for your reply.
I’ve just tried to restore Collabora from the beginning, following your howto (I did more or less the same previously, except for the ca-bundle), but it’s still not working.
Now the error message on the Nextcloud web interface is changed to "Well, this is embarrassing, we cannot connect to your document. Please try again."
Looking at the docker log of the collabora image instead now I have, repeated for each office file access trial:
wsd-00025-0030 12:56:08.705012 [ client_req_hdl ] WRN WOPI host did not pass optional access_token_ttl| wsd/FileServer.cpp:255
wsd-00025-0026 12:56:09.341848 [ client_ws_001c ] ERR Unknown resource: /lool/https://cloudserver/index.php/apps/richdocuments/wopi/files/4906_oc5opo9l987v%3Faccess_token=nd4EVbrSvVFrzD7qhoOAeD98EcUuRlxX&access_token_ttl=0&permission=edit/ws| wsd/LOOLWSD.cpp:1223
wsd-00025-0027 12:56:09.490340 [ client_ws_001d ] ERR Unknown resource: /lool/https://cloudserver/index.php/apps/richdocuments/wopi/files/4906_oc5opo9l987v%3Faccess_token=nd4EVbrSvVFrzD7qhoOAeD98EcUuRlxX&access_token_ttl=0&permission=edit/ws| wsd/LOOLWSD.cpp:1223
wsd-00025-0026 12:56:09.515275 [ client_ws_001e ] ERR Unknown resource: /lool/https://cloudserver/index.php/apps/richdocuments/wopi/files/4906_oc5opo9l987v%3Faccess_token=nd4EVbrSvVFrzD7qhoOAeD98EcUuRlxX&access_token_ttl=0&permission=edit/ws| wsd/LOOLWSD.cpp:1223

Any suggestion?