Run NextCloudClient 3.14 with an IPv6 address on Android

Hello forum,

I’m a little surprised that this topic hasn’t caused any major ripples so far.

Since the Android client 3.14, I can no longer access my NextCloud from my mobile phone with the NextCloud app.
From the same hardware via the browser no problem, just not with the app.

Sure, I’ve read the comments on IPv4 and Ipv6. Switching off IPv6 in my Fritz.Box is not an option. My setup uses a DynDNS provider that only offers IPv6.

I find it very annoying that a change is being made here with dire consequences and the only solution to this is to disable your IPv6. With the old client 3.13.x everything went wonderfully, the problems only occur with the current version.
So my solution would be how to get the whole thing back on the fly using an IPv6 address.

My complete setup:

  • DynDNS v6
  • Fritz.Box
  • Raspberry Pi
    • DockerCompose
      • Complete stack with Traefik, Gogs, Jekyll, LetsEncrypt and of course NextCloud.

I would really hope for help here.


Hi Andreas,

i actually came across the same issue with a similar setup (, DynDNS with ipv6). Had to revert back to 3.13.1 as well. So far, I could not figure out the issue, too.


1 Like

Correct answer. Took me several hours to find out what’s causing the issue, and why a friend was able to connect to my server but I am not. Sometimes early adopting new software isn’t that good of an advice.
Really hope this problem get’s fixed soon!