Rücksetzten des Passwords über E-Mail funktioniert nicht

Hallo Freunde,
ich bitte um Hilfe. Folgendes Problem.
Bei meinem Server ist die SSD eingeangen, ich habe vor Kurzem die Passwörter geändert aber leider die SSD nicht gesichert. In der letzten Sicherung sind noch die alten PWs.
Beim Rücksetzten über E-Mail bekomme ich die Meldung:

Die E-Mail zum Zurücksetzen konnte nicht versendet werden

Hier meine config.php

root@VDR:~# cat /var/www/nextcloud/config/config.php
<?php
$CONFIG = array (
  'instanceid' => 'ocet7mphvmpl',
  'passwordsalt' => 'hB7/E7hm9xIwba4s3TgLLfpzGZuJil',
  'secret' => 'Hd05vk4Ea1FUv5UL/xBcGpMzX0ucsqMDC42BKzzkobVAs173',
  'trusted_domains' => 
  array (
    0 => '192.168.123.127',
    1 => 'cloud.swtest.at',
  ),
  'datadirectory' => '/home/cloud-data',
  'dbtype' => 'mysql',
  'version' => '24.0.5.1',
  'overwrite.cli.url' => 'https://cloud.swtest.at',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextclouduser',
  'dbpassword' => 'Whpxxx',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'hansp',
  'mail_domain' => 'gmx.at',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'mail.gmx.net',
  'mail_smtpport' => '587',
  'mail_smtpname' => 'test@gmx.at',
  'mail_smtppassword' => 'Password',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpsecure' => 'tls',
);

Was mache ich falsch, muss ich einen Mailserver installieren?
Danke und LG Hans-Peter

Die Einstellungen sehen alle in Ordnung aus. Eigentlich sollte das mit der Kommunikation mit GMX funktionieren.

Du kannst aber sonst mal hier lesen, um evtl. das Passwort des Anwenders über occ auf der Kommandozeile zurückzusetzen.

Danke für die schnelle Antwort. occ ist die andere Baustelle mit der ich kämpfe.
Hier bekomme ich folgende Antwort:

root@VDR:~# /var/www/nextcloud/occ user:resetpassword nc-admin
This version of Nextcloud is not compatible with PHP>=8.2.<br/>You are currently running 8.2.6.root@VDR:~# ^C
root@VDR:~# 

daraufhin habe ich 7.4 installiert aber jetzt passiert das:

Considering dependency mpm_prefork for php7.4:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php7.4:
Module php7.4 already enabled
root@VDR:~# 

und wenn ich dann die php Version abfrage:

oot@VDR:~# php -version
PHP 8.2.6 (cli) (built: May 12 2023 06:24:00) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.2.6, Copyright (c) Zend Technologies
    with Zend OPcache v8.2.6, Copyright (c), by Zend Technologies
root@VDR:~# 

Da weis ich einfach nicht mehr weiter. Bin ja nur Hobbyanwender.
LG Hans-Peter

Wie hast du Nextcloud denn installiert und auf welcher Distro? nc-admin klingt für mich nach C. Rieger Script auf Debian oder Ubuntu…?

Was sagt denn folgender Befehl?

sudo update-alternatives --display php

Hier die Ausgabe:
Installiert auf Ubuntu 22.04 LTS

oot@VDR:~# update-alternatives --display php
php - automatischer Modus
  beste Version des Links ist /usr/bin/php.default
  Link verweist zur Zeit auf /usr/bin/php.default
  Link php ist /usr/bin/php
  Slave php.1.gz ist /usr/share/man/man1/php.1.gz
/usr/bin/php.default - Priorität 100
  Slave php.1.gz: /usr/share/man/man1/php.default.1.gz
/usr/bin/php7.4 - Priorität 74
  Slave php.1.gz: /usr/share/man/man1/php7.4.1.gz
/usr/bin/php8.1 - Priorität 81
  Slave php.1.gz: /usr/share/man/man1/php8.1.1.gz
/usr/bin/php8.2 - Priorität 82
  Slave php.1.gz: /usr/share/man/man1/php8.2.1.gz
root@VDR:~# 

Sehr wahrscheinlich nutzt du irgendwelche komischen Fremdquellen. Keine Ahnung, warum das alle bei Ubuntu machen. Das Zeug solltest du erst mal los werden. Ich nutze kein Ubuntu. Aber laut hier ist PHP 8.1 Standard. Also deinstalliere das PHP 7.4 - Zeug. Ich weiß auch nicht, wie du dir PHP 8.2 eingefangen hast. Nutzt du PPA? Wirf den Dreck doch einfach raus oder steig gleich auf Debian um. :wink: Ok PPA hat auch seine Vorteile. Aber nur dann, wenn man sie versteht.

Schau dir evtl. mal alle Pakete bzgl. PHP an und poste die Liste.

dpkg -l |grep php

Deinstalliere alles, was nicht PHP 8.1 ist. Schau evtl. irgendwo hier was dir an Pakete fehlen könnte

apache2 mariadb-server php php-cli php-fpm php-json php-intl php-imagick php-pdo php-mysql php-zip php-gd php-mbstring php-curl php-xml php-pear php-bcmath apache2 libapache2-mod-php

bzw. gleiche mal diese Liste mit deiner Installation ab. Beachte, dass diese Metapakte Pakete mit Versionsnummern nachinstallieren. Suche z. B. auch hier mit dpkg -l.

Hier die Systemanforderungen für Nextcloud 24. Du kannst und solltest Ubuntu 22.04 LTS mit der PHP 8.1 - Version der Distribution nutzen. Ignoriere irgendwelche Empfehlungen (Recommends) für PHP. Wichtig ist, dass PHP 8.1 unterstützt wird.

Laut hier ist Nextcloud 24 End of Life. Upgrade mit deinem aktuellen Ubuntu 22.04 LTS und PHP 8.1 auf Nextcloud 25 und dann auf Nextcloud 26. Nextcloud 25 und Nextcloud 26 werden von einem Standard Ubuntu 22.04 LTS mit PHP 8.1 aus der Originalquelle unterstützt siehe hier und hier. Bitte installiere keine veralteten oder neueren PHP-Versionen. Solange es läuft würde ich immer die PHP-Version der Distribution (hier Ubuntu 22.04 LTS) und nicht PPA verwenden. Die Vorteile neuerer PHP-Versionen nutzen dir nichts, wenn die Nextcloud gar nicht mehr läuft.

Zuerst mal danke für die ausführliche Antwort.
Stimmt ich habe PHP 7.4 über eine Fremdquelle installiert weil ja das occ script mit 8.2 nicht lauft.
PHP 8.2 ist momentan Standart bei Ubuntu da habe ich nichts gemacht.
Alles Andere ist original Ubuntu außer Nextcloud. Update von Nextcloud geht nicht da ich nicht in Nextcloud reinkommr (Pword vergessen).
Wenn ich nicht doch noch reinkomme muss ich Nextvloud deinstallieren und neu installieren, Aber auch das dürfte nicht so einfach sein.
LG
Hans-Peter

PS.: Ubuntu habe ich wegen einer anderen Anwendung.
Kurz gesagt ich brauche PHP 8.1 damit occ lauft.

Ich verstehe das nicht. Laut der Ausgabe ist php8.1 aktiv. (habe ich jetzt installiert)

root@VDR:~# a2dismod php8.2
Module php8.2 already disabled
root@VDR:~# a2enmod php8.1
Considering dependency mpm_prefork for php8.1:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php8.1:
**Module php8.1 already enabled**
root@VDR:~# /var/www/nextcloud/occ user:resetpassword nc-admin
This version of Nextcloud is not compatible with PHP>=8.2.<br/>**You are currently running 8.2.6.root@VDR:~#** 

Trotzdem bekomme ich bei version folgene Ausgabe:

oot@VDR:~# php -version
PHP 8.2.6 (cli) (built: May 12 2023 06:24:00) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.2.6, Copyright (c) Zend Technologies
    with Zend OPcache **v8.2.6,** Copyright (c), by Zend Technologies

Nextcloud 24 hat PHP 8.2 nicht unterstützt.

PW Rücksetzen über mail geht jetzt. (Bei Aufruf über localhost)
Danke für eure Antworten.
LG Hans-Peter

Dann kannst du ja jetzt deine Nextcloud aktualisieren.