Router error after php.ini changes

I recently changed from mpm_prefork to mpm_events together with php_fpm to enable http/2 and increace the page speed. For that I also set up redis and APCu

(here the config for that)
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis.sock’,
‘port’ => 0,
‘dbindex’ => 0,
),
and restarted the server. So far so good; everything was working.
Then, however, I changed the session handler in the php.ini from file to redi with following:
session.save_handler = “unix:///var/run/redis/redis.sock”
After this however strange errors keep poping up (cannot create session), so I disabled this again and used files again. This let me to errors that routes could not be found. I first thought this was an app error and disableda few however this just changed the router that could not be found to another app. I therefor concluded that redis might be broken (because of redis php sessions) and disabled it in the config.php:
‘memcache.local’ => ‘\OC\Memcache\APCu’,
/* ‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis.sock’,
‘port’ => 0,
‘dbindex’ => 0,
),*/
with no results. What could be the underlying error

here the twotypes of the errormessages I got:
error.txt

I forgot to include the system settings:

  • system:
    • instanceid: REMOVED SENSITIVE VALUE
    • passwordsalt: REMOVED SENSITIVE VALUE
    • secret: REMOVED SENSITIVE VALUE
    • trusted_domains:
    • datadirectory: REMOVED SENSITIVE VALUE
    • dbtype: mysql
    • version: 19.0.2.2
    • overwrite.cli.url: https://cloud.torbenarne.de
    • dbname: REMOVED SENSITIVE VALUE
    • dbhost: REMOVED SENSITIVE VALUE
    • dbport:
    • dbtableprefix: oc_
    • mysql.utf8mb4: true
    • dbuser: REMOVED SENSITIVE VALUE
    • dbpassword: REMOVED SENSITIVE VALUE
    • installed: true
    • mail_smtpmode: smtp
    • mail_smtpsecure: ssl
    • mail_sendmailmode: smtp
    • mail_from_address: REMOVED SENSITIVE VALUE
    • mail_domain: REMOVED SENSITIVE VALUE
    • mail_smtphost: REMOVED SENSITIVE VALUE
    • mail_smtpauth: 1
    • mail_smtpname: REMOVED SENSITIVE VALUE
    • mail_smtppassword: REMOVED SENSITIVE VALUE
    • mail_smtpport: 465
    • mail_smtpauthtype: LOGIN
    • maintenance: false
    • theme:
    • loglevel: 2
    • updater.release.channel: stable
    • log_query: false
    • memcache.local: \OC\Memcache\APCu
    • ldapIgnoreNamingRules: false
    • ldapProviderFactory: OCA\User_LDAP\LDAPProviderFactory

resolved it myself:
The issue: Nextcloud depends on php sessions which i misconfigured. Now I have:
session.save_handler = redis
session.save_path = “unix:///var/run/redis/redis.sock”.