RouteNotFoundException while pressing create user button

Hi guys, i got problem with create user button. For some reason clicking on it do nothing. He are some informations:

Nextcloud version: 12.0.2
php version: 7.0.22
base: centos 7.2 + nginx

Info from webgui log:

Symfony\Component\Routing\Exception\RouteNotFoundException: Unable to generate a URL for the named route "theming.Theming.getLogo" as such route does not exist.
/usr/share/nginx/html/nextcloud/lib/private/Route/Router.php - line 339: Symfony\Component\Routing\Generator\UrlGenerator->generate('theming.Theming...', Array, 1)
/usr/share/nginx/html/nextcloud/lib/private/URLGenerator.php - line 77: OC\Route\Router->generate('theming.Theming...', Array)
/usr/share/nginx/html/nextcloud/apps/theming/lib/ThemingDefaults.php - line 165: OC\URLGenerator->linkToRoute('theming.Theming...')
/usr/share/nginx/html/nextcloud/lib/public/Defaults.php - line 186: OCA\Theming\ThemingDefaults->getLogo(true)
/usr/share/nginx/html/nextcloud/core/templates/layout.guest.php - line 45: OCP\Defaults->getLogo()
/usr/share/nginx/html/nextcloud/lib/private/Template/Base.php - line 176: include('/usr/share/ngin...')
/usr/share/nginx/html/nextcloud/lib/private/Template/Base.php - line 151: OC\Template\Base->load('/usr/share/ngin...', NULL)
/usr/share/nginx/html/nextcloud/lib/private/legacy/template.php - line 202: OC\Template\Base->fetchPage(NULL)
/usr/share/nginx/html/nextcloud/lib/private/legacy/template.php - line 224: OC_Template->fetchPage()
/usr/share/nginx/html/nextcloud/lib/private/Template/Base.php - line 132: OC_Template->fetchPage()
/usr/share/nginx/html/nextcloud/core/templates/403.php - line 7: OC\Template\Base->printPage()

Info from nextcloud.log:

{“reqId”:“w8IcYucBICtT4Tm4aXrR”,“level”:3,“time”:“2017-09-05T20:36:12+00:00”,“remoteAddr”:“IP”,“user”:“Ponury Typ”,“app”:“no app in context”,“method”:“GET”,“url”:"/settings/users/users",“message”:“Exception: {“Exception”:“Symfony\\Component\\Routing\\Exception\\RouteNotFoundException”,“Message”:“Unable to generate a URL for the named route \“theming.Theming.getLogo\” as such route does not exist.”,“Code”:0,“Trace”:”#0 \/usr\/share\/nginx\/html\/nextcloud\/lib\/private\/Route\/Router.php(339): Symfony\\Component\\Routing\\Generator\\UrlGenerator->generate(‘theming.Theming…’, Array, 1)\n#1 \/usr\/share\/nginx\/html\/nextcloud\/lib\/private\/URLGenerator.php(77): OC\\Route\\Router->generate(‘theming.Theming…’, Array)\n#2 \/usr\/share\/nginx\/html\/nextcloud\/apps\/theming\/lib\/ThemingDefaults.php(165): OC\\URLGenerator->linkToRoute(‘theming.Theming…’)\n#3 \/usr\/share\/nginx\/html\/nextcloud\/lib\/public\/Defaults.php(186): OCA\\Theming\\ThemingDefaults->getLogo(true)\n#4 \/usr\/share\/nginx\/html\/nextcloud\/core\/templates\/layout.guest.php(45): OCP\\Defaults->getLogo()\n#5 \/usr\/share\/nginx\/html\/nextcloud\/lib\/private\/Template\/Base.php(176): include(’\/usr\/share\/ngin…’)\n#6 \/usr\/share\/nginx\/html\/nextcloud\/lib\/private\/Template\/Base.php(151): OC\\Template\\Base->load(’\/usr\/share\/ngin…’, NULL)\n#7 \/usr\/share\/nginx\/html\/nextcloud\/lib\/private\/legacy\/template.php(202): OC\\Template\\Base->fetchPage(NULL)\n#8 \/usr\/share\/nginx\/html\/nextcloud\/lib\/private\/legacy\/template.php(224): OC_Template->fetchPage()\n#9 \/usr\/share\/nginx\/html\/nextcloud\/lib\/private\/Template\/Base.php(132): OC_Template->fetchPage()\n#10 \/usr\/share\/nginx\/html\/nextcloud\/core\/templates\/403.php(7): OC\\Template\\Base->printPage()\n#11 {main}",“File”:"\/usr\/share\/nginx\/html\/nextcloud\/3rdparty\/symfony\/routing\/Generator\/UrlGenerator.php",“Line”:130}",“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3145.0 Safari/537.36”,“version”:“12.0.2.0”}

Info from nginx:
IP - - [05/Sep/2017:DATE +0200] “POST /settings/users/users HTTP/1.1” 403 7925 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3145.0 Safari/537.36”

(Firefox dev is confirming 403 on adres https://cloud-website/settings/users/users)

config.php:

?php
$CONFIG = array (
  'instanceid' => '*',
  'passwordsalt' => '*',
  'secret' => '*',
  'trusted_domains' =>
  array (
    0 => '*',
    1 => '*',
  ),
  'datadirectory' => '/opt/nextcloud/data',
  'overwrite.cli.url' => 'https://*',
  'dbtype' => 'mysql',
  'version' => '12.0.2.0',
  'dbname' => '*',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => '*',
  'dbpassword' => '*',
  'logtimezone' => 'UTC',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_smtphost' => '*',
  'mail_smtpport' => '465',
  'mail_from_address' => '*',
  'mail_domain' => '*',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtpname' => '*',
  'mail_smtppassword' => '*',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'updater.release.channel' => 'stable',
  'updater.secret' => '*',
);

I already tried uploading fresh files, or changing nginx settings. I got 2nd istance that is mirror in system/settings and it wroking without issue. Only difrence is between them is that 2nd istance is almost new (4 weeks) while 1st one is old (migrate it from owncloud as nextcloud came out). Any ideas how to fix this create user button issue ?

Bonus - nginx conf file:

server {
    listen 80;
    server_name *;
    # enforce https
    return 301 https://$server_name$request_uri;
}
 
server {
    listen 443 ssl;
    server_name *;

    ssl_certificate /etc/letsencrypt/live/*/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/*/privkey.pem; # managed by Certbot 

    # ssl_certificate /etc/nginx/cert/nextcloud.crt;
    # ssl_certificate_key /etc/nginx/cert/nextcloud.key;
 
    # Add headers to serve security related headers
    # Before enabling Strict-Transport-Security headers please read into this
    # topic first.
    add_header Strict-Transport-Security "max-age=15768000;
    includeSubDomains; preload;";
    add_header X-Content-Type-Options nosniff;
    add_header X-Frame-Options "SAMEORIGIN";
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;
 
    # Path to the root of your installation
    root /usr/share/nginx/html/nextcloud/;
 
    location = /robots.txt {
        allow all;
        log_not_found off;
        access_log off;
    }
 
    # The following 2 rules are only needed for the user_webfinger app.
    # Uncomment it if you're planning to use this app.
    #rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
    #rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json
    # last;
 
    location = /.well-known/carddav {
      return 301 $scheme://$host/remote.php/dav;
    }
    location = /.well-known/caldav {
      return 301 $scheme://$host/remote.php/dav;
    }
 
    # set max upload size
    client_max_body_size 512M;
    fastcgi_buffers 64 4K;
 
    # Disable gzip to avoid the removal of the ETag header
    gzip off;
 
    # Uncomment if your server is build with the ngx_pagespeed module
    # This module is currently not supported.
    #pagespeed off;
 
    error_page 403 /core/templates/403.php;
    error_page 404 /core/templates/404.php;
 
    location / {
        rewrite ^ /index.php$uri;
    }
 
    location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)/ {
        deny all;
    }
    location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console) {
        deny all;
    }
 
    location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/templates/40[34])\.php(?:$|/) {
        include fastcgi_params;
        fastcgi_split_path_info ^(.+\.php)(/.*)$;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $fastcgi_path_info;
        fastcgi_param HTTPS on;
        #Avoid sending the security headers twice
        fastcgi_param modHeadersAvailable true;
        fastcgi_param front_controller_active true;
        fastcgi_pass php-handler;
        fastcgi_intercept_errors on;
        fastcgi_request_buffering off;
    }
 
    location ~ ^/(?:updater|ocs-provider)(?:$|/) {
        try_files $uri/ =404;
        index index.php;
    }
 
    # Adding the cache control header for js and css files
    # Make sure it is BELOW the PHP block
    location ~* \.(?:css|js)$ {
        try_files $uri /index.php$uri$is_args$args;
        add_header Cache-Control "public, max-age=7200";
        # Add headers to serve security related headers (It is intended to
        # have those duplicated to the ones above)
        # Before enabling Strict-Transport-Security headers please read into
        # this topic first.
        add_header Strict-Transport-Security "max-age=15768000;
        includeSubDomains; preload;";
        add_header X-Content-Type-Options nosniff;
        add_header X-Frame-Options "SAMEORIGIN";
        add_header X-XSS-Protection "1; mode=block";
        add_header X-Robots-Tag none;
        add_header X-Download-Options noopen;
        add_header X-Permitted-Cross-Domain-Policies none;
        # Optional: Don't log access to assets
        access_log off;
    }
 
    location ~* \.(?:svg|gif|png|html|ttf|woff|ico|jpg|jpeg)$ {
        try_files $uri /index.php$uri$is_args$args;
        # Optional: Don't log access to other assets
        access_log off;
    }
}

Maybe this will help you


And on github:

Saw both of them before creating this topic, but those didnt help.