Root password for AIO VM Image

Hey all,
I’v successfully imported the All-in-One VM Image on a Proxmox VE. I want to log in on ubuntu shell, but can’t find a password for root or any other user. Does anyone know a login and password?

Hi, you get it when clicking on here: Index of /aio-vm


I have same sort of problem ive loaded the VM image and can load and sign into the linux console. with “ncadmin” and “nextcloud”
but on opening the console at port 8080 it wont accept the password “nextcloud”
so I cannot get any further !


There it should generate a new password for you the first time you open the interface and show that to you. You can now either start again with the fresh image or see How to reobtain the Nextcloud AIO password? · nextcloud/all-in-one · Discussion #1786 · GitHub

I have reloaded the virtual machine image from the original I downloaded and it still doesn’t ask me to create a password… very strange!
followed the link you gave and tried the password reset command but this errors with something about docker not found, I am not using docker I am using Virtual machine so that may be why I am guessing…
I will try downloading the image again maybe its corrupt …
Thank you

I have removed the image from virtual box and selected to remove all files.
checked virtual box folder and all files have gone.
e downloaded the Virtualbx ova image
installed it into vVrtualbox changed the network to bridged
started the appliance
signed into console with user ncadmin/nextcloud
found the ip using "ip address "
pointed browser to
It does not prompt me to create a password it just asks me to enter a password !
and it will not accept nextcloud as the password

Ive tried the suggested “sudo docker exec nextcloud-aio-mastercontainer grep password /mnt/docker-aio-config/data/configuration.json”
But this fails and on checking i dont have a /mnt/docker folder.
Probably as I am not using the docker image.
not sure what else to try !
Pau l

What do you see when you log in via the console?

It gives me the next cloud logo in Asterix .
and tells me to open ports for external access and to use port 8080 in a browser.
then drops me at the ~$ prompt.
i moved to the /mnt directory to see if the docker folder was in there as I could see the githib command for resetting aio password needed it… but its not !
but this isn’t the docker image !
I am currently downloading the image on my home PC to see if that installs any differently. I am using Virtualbox 7 at work and at home …
I can ssh into the appliance ok but obviously that gives the same as the console

Hm… Weird.

OK tried this on my home pc and it gives me a multi word password !.
But having other issues at home … It was working … Sorted ports out on router signed in and it did an update … Set the modules I wanted then 30 mins later it started starting services … But an hour later it still hadn’t started all of them …
I rebooted everything …
Now I cannot connect as it doesn’t appear to have an ip now !.
If issued ip address command but now it doesn’t show any ip 4 addresses as it did before …
I’ve googled and tried some of the suggested commands … But nothing works just errors every command I try …
Why is Linux so flaky …
Why do they keep changing commands and stuff lol… No wonder half the help on tinternet doesn’t work !
What a headache .
I’ll have a fight with the copy at work tomorrow .
Since upgrading my home machine to windows 11 virtual box is so slow … .
At least at work it’s faster …
Just wondering if my browser cache at work is causing it not to set a password …
I’ll clear it tomorrow and install another fresh copy of next cloud …

Update !
After repeated downloading the image setting up and getting do a dead end when it asked for a password
I found this
sudo cat /var/lib/docker/volumes/nextcloud_aio_mastercontainer/_data/data/configuration.json | grep password
after changing a few folder permissions to get the command to work it gave me the password and I have got in !
Very Bazzare that it behaved in the way it did ( I tried clearing the browser cashes to see if it was somehow clearing the password, but no)
At last I can finally get in !

Thank you szaimen for your support