RichDocuments error

Hi, Im seeing the following error in my logs repeatedly:

ConnectException
cURL error 6: Could not resolve host: www.shutterz.com (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://www.shutterz.com/apps/richdocumentscode/proxy.php?req=/hosting/discovery
Failed to fetch discovery: cURL error 6: Could not resolve host: www.shutterz.com (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://www.shutterz.com/apps/richdocumentscode/proxy.php?req=/hosting/discovery

The issue is that my site isnt www.shutterz.com… its www.shutterz.org

The rest of the site functions fine and few errors otherwise

Richdocuments is the internal name of nextcloud office. Check which host you have configured there.

1 Like

Im using the built in server btw… there’s no setting for the domain name. What is odd is that next cloud office is indeed working. I can open and edit documents. It’s just this error keeps showing up for no apparent reason in the logs.

I can’t seem to locate any setting or file of which next cloud office refers to the domain name. Do you know of any?

Check your config files and settings in Nextcloud (Browser, Admin-Settings).

depending on you config there are OVERWRITE* or overwrite.cli.url settings telling the system the external fqdn…

BTW I see issues with dedicated CODE in the log as well - it happens at regular intervals - mostly every 65 minutes - I think there might be a clash with background jobs or something like this… as the problem only arises from time to time

1 Like

It’s visibility in the UI is slightly different depending on version. You didn’t share any of that info in your query.

You can toggle from the built-in to… The name escapes me but the top option I believe in the UI. It will show you the URL in the field that appears.

You can also use occ config:list richdocuments to see the configured domains. That may not, though, necessarily tell you where it originally came from since there is auto configuration involved.

So please check the output of occ config:list system --private for references to that domain. (note: don’t post the output when specifying the --private since it’ll have your passwords, secrets, etc visible.

Thanks guys. In the config file, the overwrite.cli.url option, it only says http://localhost. Not seeing any reference to a .com site in the file. Very bizarre.

Could you please look and post the output of

occ config:app:get -- richdocuments wopi_url

because that is the used value on that place by the DiscoveryService.php.

The value could have slipped in there at some point and will not be overwritten if you use built in code server.


Much and good luck,
ernolf