Rich workspace loading icon

Where did this thing come from? If you visit and do a 1 click Nextcloud deploy you’ll see it. If you log into the admin or even share a file / folder, it’ll appear. I just made sure I was running latest version too, and I was not. So I even updated everything and I still see it.


If I “disable rich spaces” using the bottom left cog icon it is hidden, but how can I just disable rich workspaces globally? in web preview links and all for example?