Restrict login to ip adress app,how to use it?

I enabled ip restriction app,i added a local ip of a device which is 192.168.0.105 and when i try to access using that device it tells me i can not do that from this ip,what im doing wrong ?

Sorry, maybe I’m missing your point, but isn’t that exactly what’s supposed to happen when you add this device’s IP to the Restrict login to IP ranges?

Hi @mohanad_Raheem

you did not fill out the support template.
Do you host it at home in your local network?
How is the DNS managed?

As far as I understand → the README of that app ← , you have to specify an IP range in CIDR-block Notation.

If you want to only restrict it to one IP, then the CIDR Notation is

  • 192.168.0.105/32

Much and good luck,
ernolf

2 Likes

Yeah, I got it wrong. @ernolf is right. Try 192.168.0.105/32 if you only want to allow that specific device.

thanks for the reply,yes its setup only to be accessed by local network,i tried the ip followed by 32 but still it will not let me access

thanks for the reply,sorry i didnt explain in details,the IPs i add are the whitelist IPs

Are you using a FQDN, e.g. cloud yourdomain.tld, that resolves to the public IP address of your Internet connection in order to access your Nextcloud?

If so, your router is probably doing NAT loopback/NAT reflection, which means that all requests from the devices on your LAN are rewritten to the local IP address of your router, with the result that Nextcloud can’t see the actual IP address of the device that has sent the requests.

In this case, you cannot whitelist individual local devices, respectively you first need to make sure that cloud.yourdomain.tld resolves to the LAN address of your Nextcloud. One way to do this would be to set up a local DNS server and add a corresponding DNS record for your Nextcloud.

Its complicated for me to do the setting you mentioned,i will limit the devices connected to my network by doing a mac address filtering using the router ui .
Thanks for your time and effort