Restoring point disappeared

Hi there.
I tried to do a first backup with the Backup App to an external HDD. All pre-configuration seem to have gone correct and it all seemed to work. I used pretty much all the default settings. No compression. No encryption.

It took a few days for my 50GB Nextcloud to show me a „packed“ status in the GUI and via „occ backup:point:list“ and I thought I would wait a bit longer to let it upload to my external HDD. But now it all disappeared. Gone. It does not show up anymore neither in the History of restoring points in the GUI nor via occ backup:point:list.
Any idea what could have gone wrong and what I need to do to get the Backup App to work properly?

Ubuntu 20.04
PHP 7.4.3
MySQL 8.0.31

Can I follow up on this one?
I tried again. The backup was successfully created locally.
I then packed it via occ backup:poin:pack and then tried to upload it to my external HDD.
The mount point and that all works fine.
But now I get the following error message:

serveradmin@meinserver:/var/www/nextcloud$ sudo -u www-data php occ backup:point:upload 20230122234004-full-XXXXXXXXXXXXXXX
- uploading 20230122234004-full-XXXXXXXXXXXXXXX to external folders
 - checking external folder 13:NCBackup
  > restoring point not found
  * Creating Restoring Point on external folder: No create permission for folder
  ! cannot create restoring point
 ! issue while checking external folder: OCP\Files\NotPermittedException No create permission for folder

How do I give the Backup App permission to create a folder on my external HDD?
Can anybody help?

funnily - or sadly - enough the restoring point now dissapeared again after a few days without me doing anything.

Is there anybody who is using the Backup App successfully? Is that even a viable option?

Unfortunately I don’t use this app so I have no answer for you… however have you checked out the GitHub page?

The README has quite a lot of information regarding how to setup this App

Regarding the permissions issue, did you setup a folder from the External Storage Settings page first?

The first step is to setup a folder from the External Storage Settings Page, it is strongly adviced to limit the availability of the folder to the admin group only:
Source: GitHub - nextcloud/backup: Backup now. Restore later.

Losing the backup points sounds like a possible bug maybe? Might be a good idea creating an issue on the GitHub page if it persists after setting up the external storage folder as described in the README

Backup App on GitHub: GitHub - nextcloud/backup: Backup now. Restore later.

Below is the regular backup flow from the Nextcloud documentation

1 Like