# Restarting Docker results in "Failed to fork child processes"

**URL:** <https://help.nextcloud.com/t/restarting-docker-results-in-failed-to-fork-child-processes/12209>\
**Category:** 📄 Office\
**Tags:** collabora-online\
**Created:** [May 5, 2017, 12:27pm UTC](https://help.nextcloud.com/t/restarting-docker-results-in-failed-to-fork-child-processes/12209 "2017-05-05T12:27:54Z")\
**Posts on this page:** 6\
**Page:** 2

<div class="post-metadata">

**Author:** ![ripper17](https://help.nextcloud.com/letter_avatar/ripper17/32/5_5575768a8748004e209b776fc1b2916d.png) [@ripper17](https://help.nextcloud.com/u/ripper17)\
**Post date:** [July 7, 2017, 2:31pm UTC](https://help.nextcloud.com/t/restarting-docker-results-in-failed-to-fork-child-processes/12209/23 "2017-07-07T14:31:18Z")

</div>

I marked the thread as solved because it currently works for me. Maybe I just got lucky and it’s some kind of race-condition that sometimes (most of the times actually) leads to the error, but sometimes works. Try restarting againg and again (if you have the time) and see if it works at some point.

I’ve not dared to restart my docker since it is currently running (and I still don’t think I did anything to fix any issue).

I’ll remove the “Solved” to draw some more attention as this does seem to be still a problem…

---

<div class="post-metadata">

**Author:** ![jmcclelland](https://help.nextcloud.com/letter_avatar/jmcclelland/32/5_5575768a8748004e209b776fc1b2916d.png) [@jmcclelland](https://help.nextcloud.com/u/jmcclelland)\
**Post date:** [August 12, 2017, 4:50pm UTC](https://help.nextcloud.com/t/restarting-docker-results-in-failed-to-fork-child-processes/12209/24 "2017-08-12T16:50:43Z")

</div>

I’m not sure this is a collabora issue. It might be a docker issue.

I had the same problem while running Debian Jessie with the latest version of docker-ce from the docker debian repo.

Then, I purged docker and re-install the ancient version 1.6.2 from debian jessie backports and it all works fine.

---

<div class="post-metadata">

**Author:** ![cloudShepherd](https://help.nextcloud.com/letter_avatar/cloudshepherd/32/5_5575768a8748004e209b776fc1b2916d.png) [@cloudShepherd](https://help.nextcloud.com/u/cloudShepherd)\
**Post date:** [January 4, 2018, 6:46pm UTC](https://help.nextcloud.com/t/restarting-docker-results-in-failed-to-fork-child-processes/12209/25 "2018-01-04T18:46:33Z")

</div>

I’ve just tried to updated my collabora docker container as described at the official website, an I was getting the following errors:

```
wsd-00026-00026 18:05:30.232264 [loolwsd] FTL Failed to fork child processes.| wsd/LOOLWSD.cpp:2703                                                                                                             
FATAL: Failed to fork child processes.                                                                                                                                                                             
wsd-00026-00026 18:05:30.232539 [loolwsd] FTL Failed to fork child processes.| wsd/LOOLWSD.cpp:2853                                                                                                             
Failed to fork child processes.                                                                                                                                                                                    
wsd-00026-00026 18:05:30.232786 [loolwsd] WRN Waking up dead poll thread [admin], started: false, finished: false| ./net/Socket.hpp:507                                                                         
wsd-00026-00026 18:05:30.232859 [loolwsd] WRN Waking up dead poll thread [admin], started: false, finished: false| ./net/Socket.hpp:507                                                                         
wsd-00026-00026 18:05:30.233457 [loolwsd] WRN Waking up dead poll thread [delay_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                    
wsd-00026-00026 18:05:30.233566 [loolwsd] WRN Waking up dead poll thread [delay_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                    
<shutdown>-00026 18:05:30.234974 [loolwsd] WRN Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235091 [loolwsd] WRN Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235108 [loolwsd] WRN Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235126 [loolwsd] WRN Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235142 [loolwsd] WRN Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235159 [loolwsd] WRN Waking up dead poll thread [accept_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235497 [loolwsd] WRN Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
<shutdown>-00026 18:05:30.235559 [loolwsd] WRN Waking up dead poll thread [websrv_poll], started: false, finished: false| ./net/Socket.hpp:507                                                                  
frk-00028-00028 18:05:30.239049 [forkit] FTL Pipe closed.| common/IoUtil.cpp:308

```

,which seems similar to the one already mentioned and the container constantly restarts after ~1minute. I’ve recreated the container again and restarted the container and the docker service without any improvements. I also noticed, that the new image is quite a bit smaller:

```
REPOSITORY TAG IMAGE ID CREATED SIZE                     
collabora/code latest b953105d9a65 2 weeks ago 1.42 GB                  
collabora/code <none> 0e6e649ddcae 7 weeks ago 2.06 GB

```

For now I’ve just reverted to the old image, which works.  
Have I’ve been overlooked something on my side or is the docker image broken again?

---

<div class="post-metadata">

**Author:** ![tom55](https://help.nextcloud.com/letter_avatar/tom55/32/5_5575768a8748004e209b776fc1b2916d.png) [@tom55](https://help.nextcloud.com/u/tom55)\
**Post date:** [May 18, 2018, 7:27am UTC](https://help.nextcloud.com/t/restarting-docker-results-in-failed-to-fork-child-processes/12209/26 "2018-05-18T07:27:28Z")

</div>

to cloudShepherd,  
I got the same error and found solution - each time you update Collabora image in docker you have to go to web interface of Nextcloud, then to “Settings/Collabora online” and just push “Apply” button beneath “Collabora online server”.

---

<div class="post-metadata">

**Author:** ![wwe](https://help.nextcloud.com/user_avatar/help.nextcloud.com/wwe/32/72963_2.png) [@wwe](https://help.nextcloud.com/u/wwe)\
**Post date:** [December 2, 2024, 2:06pm UTC](https://help.nextcloud.com/t/restarting-docker-results-in-failed-to-fork-child-processes/12209/27 "2024-12-02T14:06:55Z")

</div>



---

<div class="post-metadata">

**Author:** ![wwe](https://help.nextcloud.com/user_avatar/help.nextcloud.com/wwe/32/72963_2.png) [@wwe](https://help.nextcloud.com/u/wwe)\
**Post date:** [December 4, 2024, 1:23pm UTC](https://help.nextcloud.com/t/restarting-docker-results-in-failed-to-fork-child-processes/12209/28 "2024-12-04T13:23:26Z")

</div>



[Previous page](https://help.nextcloud.com/t/restarting-docker-results-in-failed-to-fork-child-processes/12209.md?page=1)
