Resharing not allowed after upgrade


#1

Hello there !

Nextcloud version : 14.0.1
Operating system and version : Ubuntu 16.04.5
Apache or nginx version : Nginx 1.10.3
PHP version : 7.1.22

The issue you are facing:

After upgrading with occ command from version 13.0.2 to 13.0.6 (everything went apparently well) when any user hit “share” there is a message greyed out “resharing is not allowed”. I tried to upgrade to 14.0.1, same.

Is this the first time you’ve seen this error? : Y

Steps to replicate it:

  1. log in with a user
  2. try to share a file/folder
  3. you can’t : “resharing is not allowed”

The output of your Nextcloud log when hitting share:

{"reqId":"YYkSKjry0zWwiPt7jQJf","level":0,"time":"2018-10-08T22:45:49+00:00","remoteAddr":"82.123.96.217","user":"xxx","app":"no app in context","method":"GET","url":"\/apps\/files\/","message":"No cache entry found for \/appdata_ochspm1e30yv\/theming\/images\/background (storage: local::\/var\/www\/nextcloud\/data\/, internalPath: appdata_ochspm1e30yv\/theming\/images\/background)","userAgent":"Mozilla\/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko\/20100101 Firefox\/62.0","version":"14.0.1.1"}
{"reqId":"bPC5Op7iPcWvHm9W6VwD","level":0,"time":"2018-10-08T22:45:49+00:00","remoteAddr":"82.123.96.217","user":"xxx","app":"no app in context","method":"GET","url":"\/apps\/files\/","message":"No cache entry found for \/appdata_ochspm1e30yv\/theming\/images\/background (storage: local::\/var\/www\/nextcloud\/data\/, internalPath: appdata_ochspm1e30yv\/theming\/images\/background)","userAgent":"Mozilla\/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko\/20100101 Firefox\/62.0","version":"14.0.1.1"}
{"reqId":"ZydkH6HcLfE2k2OYvkDM","level":0,"time":"2018-10-08T22:45:50+00:00","remoteAddr":"82.123.96.217","user":"xxx","app":"no app in context","method":"GET","url":"\/apps\/files\/","message":"No cache entry found for \/appdata_ochspm1e30yv\/theming\/images\/background (storage: local::\/var\/www\/nextcloud\/data\/, internalPath: appdata_ochspm1e30yv\/theming\/images\/background)","userAgent":"Mozilla\/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko\/20100101 Firefox\/62.0","version":"14.0.1.1"}

The other are not relevant but I can give them if necessary.

Thanks in advance for your help !


#2

Hi,

Could you please check your sharing settings and let us know your settings in that section?


#3

Hi Schmu ! Thanks for the quick answer

Yes it is checked, and I tried to uncheck/check again : same…

But when I load this settings I get an error on top “can’t get/retrieve groups’ list” or something like that, my language is French… I can try to set English if this helps.
But maybe it’s unrelated ?


#4

OK the exact message is “Unable to retrieve the group list”.

I got the same in settings/admin/additional, maybe this is it ? I can’t find anything except locales on this error… Should I open a bug ?

Nothing in logs too, even level 0…


#5

Still on it… I noticed that the users are not displaying as well ! I’m getting “An error occured during the request. Unable to proceed.”

I looked up the internet, saw that it might be a encoding issue so I tried https://docs.nextcloud.com/server/14/admin_manual/configuration_database/mysql_4byte_support.html to reset everything to what’s recommended but same problem…

I dread to be running out of options soon :frowning:


#6

Hi,

Sorry, that I hadn’t found the time to answer earlier.
Your issue sounds strange and I’m not sure if I can really help here. What we can try to have a look at, is the log file again. Could you please increase the log level to Info or even Debug, perform all the steps where you noticed any issue and provide the log file afterwards?
I would suggest to open the Browser Console as well and check for error messages there as well. Just to avoid that some scripts are blocked by CSP or something like that.


#7

Hi Schmu,

Don’t apologize, it’s very nice of you to try to help ! Sorry to be late to reply…
I have nothing in logs server side, even with debug set (on Nextcloud, haven’t tried to increase PHP or Nginx log level but I think it’s no use).
BUT ! On client, my browser, I get this : " Object { users: Getter Setter, apps: Getter Setter, settings: Getter Setter, oc: Getter Setter, route: Getter Setter, … } TypeError: “e.data.ocs is undefined”"

We might have something here don’t we ?


#8

Hi,

Definitely looking strange. Can you make a screenshot of the full message and post it here? With every detail (the browser console usually outputs the file which caused this error), please.
I hope this brings us closer to a solution :slight_smile:


#9

Here goes !


I realized I have the same error on the files page but I suppose this is logical.


#10

Hello,

Sorry, trying a little UP, I’m still stuck and can’t resolve to restart from scratch… I would love to set Nextcloud professionally and this is frustrating !
Should I open an official bug ?


#11

I am also experiencing this issue. However, I have a slightly different set of error messages:


I am on:

  • Debian Testing
  • NC 14.0.3
  • nginx 1.14.0
  • PHP 7.2.9

#12

Hello !

Trying a little UP here… I updated to 14.0.4, same issue. I tried to switch to bigint with db:convert-filecache-bigint to see if it might help but still the same…


#13

If you have updated to NC 14.0.4, you can try to download the complete installer and just re-install NC again. Please copy your config.php aside and take care of your data directory, if it resides inside your NC instance folder.

Trying to access the new instance should immediately prompt you to perform an update… do so, as this will download all additional apps from the NC app store again.

You probably also want to perform a full database backup before proceeding any further…


#14

Thanks for your input !

Tried that, back of data folder and config.php, then recreating nextcloud/ from the last stable archive, and restoring date + config but wasn’t ask to upgrade (I tried occ command first).
Now all apps are default but I still have the issue !