Removing a shared resource not possible in NC 15.0.0

I use NC 15.0.0, PHP 7.2.

When going to the shares and clicking one, I cannot remove the share. Same is for shared links, where I cannot click the “Share Link” button. I’m not sure how I can remove it. It seems broken? Previously in NC 13 it was in that menu…

This is possibly related to as well.

You missing the three dots on the right site of the share. Maybe a theme problem?

1 Like

I use the default dark theme from nextcloud. But I have found out the icon issue:
I had to use:
sudo -u www-data php occ maintenance:repair

To fix the missing icons. Sadly, removing a share still doesn’t work. I can delete the entire folder/file now, but not removing the share.

It looks like this now:

I tried to change to the default Nextcloud theme, but it behaves exactly the same.

I think you are clicking the wrong menu :wink:

I do not have this … menu item there. There is only the “can edit” checkbox:

HTML code (see, it’s completely missing!):

Okay, so this seems to be some really weird issue.

I could fix it! But I’m not sure if it is permanent. I had to do the following things:

  1. Locate the HTML where the buttons would be

  2. Select the share-menu item and look at the CSS properties. You’ll see that display: block is striked through, which means that some other rule overwrites it.

  3. There is a display: none!important attribute in some other element that affects this element. Disabling it in the browser F12 window fixed the error.

  4. It seems that after doing this, the display:none!important attribute doesn’t get added back after a page reload, which is good.


Maybe this was a caching issue? You could try to clear your browser cache now, fully reload the page and see if the problem re-occurs.

Okay, I found the problem. Just tried opening the site in another browser window in private mode. I use Firefox 64.0, the current latest one.
I see the following CSS rule:

This rule looks like a filter rule, since it’s pretty large and has this !important flag there. So I tried to disable uBlock origin, and voilà, the buttons appear. Note: uBlock origin did show 0 of 0 elements blocked which would actually mean that it didn’t block anything. But in fact, it did…

1 Like

Wow, what a bummer. :man_facepalming:
Great job finding the root cause! I will keep uBlock origin in mind in case somebody else stumbles across such an issue and reports it here.

1 Like

If someone else runs into that issue: Instead of disabling uBlock completely, one can hit that button there in the settings menu to disable “cosmetic filtering”. This is the feature that inserts these display:none!important flags everywhere.

1 Like