Removed slashdomain "/nextcloud" and navi icons dissapear :)

Hi to all,

Reading all topics here, i feel this “issue” is piece of cake, and realy not big problem, but I will post for finding solution for solving.
My instalation of nextcloud was installed as slashdomain by default myhost/nextcloud , but on Apache server i have changed default web to be /var/www/nextcloud (instead by default /var/www). And now when I type myhostname, directy I’m receiving login page, which is great !

After making this change, some of icons start to dissapear, built-in icons of menus:

As you can see there is no icons for drop-down menu, no upload icon, and few more icons not shown in this screenshot.

In source code i see this:

And if I remove “nextcloud” in path, I can see icon:

I’m not developer… I see the reason for problem, but I can’t find right solution. Anybody knows how to fix this in few steps?

Thank you, and have a nice weekend.

Nextcloud version: 11.0.2
Operating system : Ubuntu 16.04.02
Webmin version: 1.831
Apache version: Apache 2.4.18
PHP version : 7.0.15
SQL version: 5.7.17

Did you restart your server and all the caching modules?

Yes of course, I have restarted server several times. The whole server (Ubuntu). Nothing else changed/restarted. You have any idea?

You can use this option in your config/config.php:

 * Nextcloud attempts to detect the webroot for generating URLs automatically.
 * For example, if ```` is the URL pointing to the
 * Nextcloud instance, the webroot is ``/nextcloud``. When proxies are in use,
 * it may be difficult for Nextcloud to detect this parameter, resulting in
 * invalid URLs.
'overwritewebroot' => '',

Do you use a reverse proxy?

No, i don’t use any proxy. Its public static IP only for that machine.
In config.php I dont see any “overwritewebroot” line, so i have added ‘overwritewebroot’ => ‘’, and now I don’t have any icons on menus.

Now I have changed with ‘overwritewebroot’ => ‘’, and rebooted the server … now the nextcloud is not accessible. What should i write between ‘’ ? Sorry for lame questions :slight_smile:

Just leave it empty '' because you don’t use a subfolder.