Remove remote.php by using a subdomain - apache

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): filerun fork
Operating system and version (eg, Ubuntu 20.04): Debian 11
Apache or nginx version (eg, Apache 2.4.25): Apach2.4.56
PHP version (eg, 7.4): 8.2

The issue you are facing:

So, I’m using Infuse for accessing my movies and so on on my server, but only using SMB for now. Webdav is supported, but it’s not supporting the .php extension.
My idea is now to create a subdomain, with a redirection to the real domain, but the .php extension is not needed. I tried multiple rewrite rules in apache, but I’m not getting it.

So, the idea in the end is to do this : ->

I started with something like this :

RewriteEngine on

RewriteCond %{SERVER_NAME}

RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

But I don’t really know how to finish this.

Thanks to all ! :slight_smile:

PS : I know, it’s not exactly for next cloud, but this will also be a solution for next cloud and Infuse :slight_smile:

What do you mean by this? Are you saying Infuse supports WebDAV but has some issue with URLs with file extensions?

Sorry for the late reply, I was expecting an email :slight_smile:

Yes, pretty much. The WebDAV option is present, but it only wants the address, and whatever I put after it will simply remove it, and use the remote.php as a location. Which means, the php file is simply not executed at all, so the WebDAV protocol is not starting.

Here is a topic I created for infuse forums years ago…