Registration error

docker
#1

Hello Here.

I have a problem after installation of nextcloud in docker and install the registration module for user registration I get an error went trying to register after an email address.

this is the message error

Internal Server Error

The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.

Technical details

  • Remote Address: 154.72.168.165
  • Request ID: 7ntPNZuSDUApn4aPs0uw

any solution or idea will be grateful
thanks

#2

Are there no log files on the server?

#3

all log file that I look was not saying something that can help me solve the problem

#4

What’s in the protocol of nextcloud itself?

#5

I’m not getting your question.
But I install using docker and the problem is when I want somebody to register through the the registration module

#6

There is the Logging Tab in the Settings/Administration screen. Should contain some hints.

#7

I face the same problem, registration does not work, similar error as described above, but sending test emails from admin interface is working.
My Nextcloud logs show the following entry:
"[index] Error: Swift_TransportException: Expected response code 354 but got code “554”, with message "554 5.5.1 Error: no valid recipients
" at <>

  1. /var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 341
    assertResponseCode(“554 5.5.1 Error … n”, [354])
  2. /var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/EsmtpTransport.php line 305
    executeCommand(“DATA\r\n”, [354], [“candidate_email-address”], false, null)
  3. /var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 390
    executeCommand(“DATA\r\n”, [354], [“candidate_email-address”])
  4. /var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 497
    doDataCommand([“candidate_email-address”])
  5. /var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 516
    doMailTransaction(Swift_Message {}, “admin_email-address”, [“candidate_email-address”], [“candidate_email-address”])
  6. /var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php line 206
    sendTo(Swift_Message {}, “admin_email-address”, {candidate_email-address: null}, [“candidate_email-address”])
  7. /var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Mailer.php line 71
    send(Swift_Message {}, [“candidate_email-address”])
  8. /var/www/nextcloud/lib/private/Mail/Mailer.php line 180
    send(Swift_Message {}, [“candidate_email-address”])
  9. /var/www/nextcloud/apps/registration/service/mailservice.php line 101
    send(OC\Mail\Message {})
  10. /var/www/nextcloud/apps/registration/controller/registercontroller.php line 90
    sendTokenByMail(OCA\Registration\Db\Registration {id: 33})
  11. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 166
    validateEmail(“candidate_email-address”)
  12. /var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 99
    executeController(OCA\Registration … {}, “validateEmail”)
  13. /var/www/nextcloud/lib/private/AppFramework/App.php line 118
    dispatch(OCA\Registration … {}, “validateEmail”)
  14. /var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
    main(“OCA\Registrati … r”, “validateEmail”, OC\AppFramework\ … {}, {_route: "regist … "})
  15. <>
    __invoke({_route: "regist … "})
  16. /var/www/nextcloud/lib/private/Route/Router.php line 297
    call_user_func(OC\AppFramework\ … {}, {_route: "regist … "})
  17. /var/www/nextcloud/lib/base.php line 987
    match("/apps/registration/")
  18. /var/www/nextcloud/index.php line 42
    handleRequest()

POST /index.php/apps/registration/
from 84.139.131.49 at 2019-02-04T08:43:55+01:00"

Any ideas what is going wrong and how to fix it?

#8

No one in Nextcloud universe having an idea for a solution of my problem? :-/

#9

2019-02-12:
Noticed update notification to NC 15.0.4 today. Updated system, but problem persists.

2019-02-22:
Nobody having an advice with this issue? It prevents users from registering themselves …

2019-03-13:
Updates instance to 15.0.5 today, no positive effect on self-registration. Removed app “Registration” and installed it again, no change. Problem persists.
I have no idea what I can do.

#10

I have same problem here:

CentOS 7.6.1810 updated al lastest
NC 15.0.5
PHP 7.2.14 (from webstatic repo)
Registration App 0.4.5

Registration send link via email,
Follow the link to register a new user/pass,
Webpage report:
Internal Error
And asked to contact admin for more detail.

I have try to add new users with same attribute within user interface, that’s no problem, only self registration cannot complete the process.

nextcloud log recorded as:

{“reqId”:“XItByorXj6u9QVTTWn5fxgAAAA0”,“level”:3,“time”:“2019-03-15T14:10:20+08:00”,“remoteAddr”:“192.168.0.200”,“user”:"–",“app”:“index”,“method”:“POST”,“url”:"/index.php/apps/registration/verify/XBOYC3",“message”:{“Exception”:“Error”,“Message”:“Call to undefined method GuzzleHttp\Client::request()”,“Code”:0,“Trace”:[{“file”:"/var/www/html/nextcloud/apps/lookup_server_connector/
lib/UpdateLookupServer.php",“line”:132,“function”:“delete”,“class”:“OC\Http\Client\Client”,“type”:"-",“args”:“https://lookup.nextcloud.com/users",{“body”:"{“message”:{“data”:{“federationId”:“sysnotify@10.150.0.198”},“type”:“lookupserver”,“signer”:“sysnotify@10.150.0.198”,“timestamp”:1552630220},“signature”:“d0Jnmk8ztePdgd+vrVeG9T2LqEbaiYB8DdAhhzjTv\/FaymuqZS0LkEJ4c0WX9amiPqI77cMoH\/B29CenZxDH032jnsF9ZEnWIOhSJOr\/P4JdgRrXxr9Zo+jULbsUaupvJkPnNeFHOjoct69bKlYvvxiGa5vlCxchQ0ZsWWom1IizpHxOSyV72dg2SWMO2sFiU\/w0GqKEBhbMGrvnF2dfxp8mCdpyp5Jc+srZQ4wgXVGFnORtuN7ToIp2JnxbDh79GnXwgQP+BVYySd8NTRU5a9DW83bfxBFZ9fw2zsFyL0g58Dp1j\/Dk6M\/\/NozEj29yuxpwIPsUfWkLzM59pM3Nsg==”}",“timeout”:10,“connect_timeout”:3}]},“file”:"/var/www/html/nextcloud/apps/lookup_server_connector/lib/UpdateLookupServer.php",“line”:95,“function”:“sendToLookupServer”,“class”:“OCA\LookupServerConnector\UpdateLookupServer”,“type”:"->”,“args”:["*** sensitive parameter replaced***",]]},“file”:"/var/www/html/nextcloud/apps/lookup_server_connector/appinfo/app.php",“line”:30,“function”:“userUpdated”,“class”:“OCA\LookupServerConnector\UpdateLookupServer”,“type”:"->",“args”:["*** sensitive parameter replaced ***"]}

It looks like someone try to contact the lookup.nextcloud.com server, but it has no response. I have try to disable federation has no help.

I have no idea about how can I troubleshoot it?

#11

I face plus or minus the same problem here despite I don’t use federation.

My NC is a freshly installed one (for debuguing problems with our ldap server which doesn’t support rfc2696 “simple paged”). It is currently currently syncing tons of accounts from a the ldap. For some reason, the “VerifyUserData” task spends a lots of time querying https://lookup.nextcloud.com which persists to reply with a 503 Service Unavailable.

I have had to set “lookup_server” to “” in order to get rid of that but I’m not sure it’s the best way to deal with that problem.


Olivier

#12

Thanks for the tip: tried it, now registration emails are sent. Great!

However, I don’t know either, whether this setting has any negative side effects.
Does anyone know?

I also tried to set this parameter to the default. My original config did not include this setting so I thought it might be worth to try. This also seems to work! So probably the whole issue is caused by wrong defaults when this key is not set at all.