RedisException after restoring ncp on a fresh install

Hi,

after I restored my nextcloudpi on a fresh install, I want to get out of maintenance mode and suddenly this error appears:

root@nextcloudpi:~# sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --off
An unhandled exception has been thrown:
RedisException: WRONGPASS invalid username-password pair or user is disabled. in /var/www/nextcloud/lib/private/RedisFactory.php:123
Stack trace:
#0 /var/www/nextcloud/lib/private/RedisFactory.php(123): Redis->auth()
#1 /var/www/nextcloud/lib/private/RedisFactory.php(158): OC\RedisFactory->create()
#2 /var/www/nextcloud/lib/private/Memcache/Redis.php(70): OC\RedisFactory->getInstance()
#3 /var/www/nextcloud/lib/private/Memcache/Redis.php(76): OC\Memcache\Redis->getCache()
#4 /var/www/nextcloud/lib/private/App/InfoParser.php(58): OC\Memcache\Redis->get()
#5 /var/www/nextcloud/lib/private/App/AppManager.php(724): OC\App\InfoParser->parse()
#6 /var/www/nextcloud/lib/private/AppFramework/App.php(72): OC\App\AppManager->getAppInfo()
#7 /var/www/nextcloud/lib/private/legacy/OC_App.php(154): OC\AppFramework\App::buildAppNamespace()
#8 /var/www/nextcloud/lib/private/AppFramework/Bootstrap/Coordinator.php(119): OC_App::registerAutoloading()
#9 /var/www/nextcloud/lib/private/AppFramework/Bootstrap/Coordinator.php(90): OC\AppFramework\Bootstrap\Coordinator->registerApps()
#10 /var/www/nextcloud/lib/base.php(700): OC\AppFramework\Bootstrap\Coordinator->runInitialRegistration()
#11 /var/www/nextcloud/lib/base.php(1200): OC::init()
#12 /var/www/nextcloud/console.php(48): require_once('...')
#13 /var/www/nextcloud/occ(11): require_once('...')

Can somebody tell me if this is bad and/or how to solve it?

Thank you very much in advance!

You restored Nextcloud but did you restore redis as well?

It looks like as if the redis user defined in your old redis server is not created with the password defined in config/config.php

But unfortunately I don’t know enough about the structure of ncp to really be able to help.


Much and good luck,
ernolf

Hi Ernolf,

no i didn’t since the docs don’t suggest anything in that direction:
https://docs.nextcloud.com/server/stable/admin_manual/maintenance/restore.html#restore-folders

It’s not the data in redis. If you connect to redis, and the user/pw for the connection has changed, you need to update this in your config.php.

1 Like

A restart solved the problem.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.