Redis on 100% CPU

I’m running a docker container with nextcloud (nextcloud:apache), postgresql 11.10 (postgres:11) and redis 6.0.10 (redis:6-alpine).

Anything worked since I had to reboot the raspi. After that, the database was corrupt, I had to reinitialize it and restore my backup. Now Nextcloud is working again.

But I have two problems with redis. I don’t know if they are related:

  1. redis is using 100% CPU time. After some time it uses even two cores completly.
  2. the redis container has a corrupt time.
    The log shows me
    pi@tsht2:/data/nextcloud $ docker logs nextcloud_redis_1
    1:C 01 Jul 2071 01:14:16.000 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
    1:C 01 Jul 2071 01:14:16.000 # Redis version=6.0.10, bits=32, commit=00000000, modified=0, pid=1, just started
    1:C 01 Jul 2071 01:14:16.000 # Configuration loaded
    1:M 01 Jul 2071 01:10:48.000 # Warning: 32 bit instance detected but no memory limit set. Setting 3 GB maxmemory limit with ‘noeviction’ policy now.
    1:M 01 Jul 2071 01:13:28.000 * Running mode=standalone, port=6379.
    1:M 01 Jul 2071 01:14:16.000 # Server initialized
    1:M 01 Jul 2071 01:14:08.000 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
    1:M 01 Jul 2071 01:14:16.000 * Ready to accept connections
    Redis seems to start correctly, but the date/time is weird.

When I look into the container it gets even more weird:
pi@tsht2:/data/nextcloud $ docker exec -it nextcloud_redis_1 date
Sun Jan 0 00:100:4174038 1900

I tried to remove the redis container and the image and to restart with a new image, but to no avail.

Do you have an idea what happens there?

1 Like

It seems the alpine image is broken for arm7 at the moment:

or to be more specific
[Release Notes for Alpine 3.13.0 - Alpine Linux]

I changed the redis image from :6-alpine to :latest and now it works again.
BTW: It seems that was the problem with my database, too… while restoring I changed it from :10-alpine to :11, not knowing that that did the trick. :wink:

1 Like