Really Slow reaction of the website

Nextcloud version: 19.0.5
Operating system and version : Centos 7.9.2009
Apache version : 2.4.6-97
PHP version: 7.4.12

For a couple of while i got the problem, that my website is really slow if i press something on the menu bar it tooks quit a long time until the folder and the content show up. The same is with the calender, contacts or all other apps. Also if i try to edit a Document, onlyoffice take soooooo long to open and start.

I try a couple of things, but got no ideas what else i can do.

The server is locally in my network, my both other server in the internet with a similar config running smothly.

Anybody a idea or a guess what i can check?

Thanks & Regards
gerribaldi

Could be a lot of things, I would start to check with the top and iftop command if some process is taking to many resources. You could be out of memory causing the system to use swap. A to high IO, cpu or network load can also be it. Next check the logs, NC and system, see if any errors can tell you more.

I got a core i5-2400 with 16gb ram. The RAM load is 8GB avarage and CPU load is 20-30%, iostat show most time 85% idle time if i try to access via web.

The other webserivces like kolab or tt-rss are running without any problems.

firts lock at the NC and system logs show nothing special.

Not sure if this will help, but I was experiencing something similar. I disabled the following apps and it seemed to solve the slowness. Not sure which one was the hog. I may enable them one by one again:

  • ransomware_protection
  • richdocumentscore
  • richdocuments
  • dashboard
  • accessibility

i disabled the apps ransomware and accessibility without effect - the others where not installed.

The NC log show only this

[PHP] Error: Error: Undefined index: from at /var/www/wolke/apps/ojsxc/lib/stanzahandlers/iq.php#86 at <>

  1. /var/www/wolke/apps/ojsxc/lib/stanzahandlers/iq.php line 86
    OC\Log\ErrorHandler::onError(8, “Undefined index: from”, “/home/datengrab … p”, 86, {stanza: {name: … "})
  2. /var/www/wolke/apps/ojsxc/lib/Controller/HttpBindController.php line 194
    OCA\OJSXC\StanzaHandlers\IQ->handle({name: "{jabber: … }})
  3. /var/www/wolke/lib/private/AppFramework/Http/Dispatcher.php line 170
    OCA\OJSXC\Controller\HttpBindController->index()
  4. /var/www/wolke/lib/private/AppFramework/Http/Dispatcher.php line 100
    OC\AppFramework\Http\Dispatcher->executeController(OCA\OJSXC\Contro … {}, “index”)
  5. /var/www/wolke/lib/private/AppFramework/App.php line 137
    OC\AppFramework\Http\Dispatcher->dispatch(OCA\OJSXC\Contro … {}, “index”)
  6. /var/www/wolke/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
    OC\AppFramework\App::main(“HttpBindController”, “index”, OC\AppFramework\ … {}, {_route: “ojsxc.http_bind.index”})
  7. <>
    OC\AppFramework\Routing\RouteActionHandler->__invoke({_route: “ojsxc.http_bind.index”})
  8. /var/www/wolke/lib/private/Route/Router.php line 297
    call_user_func(OC\AppFramework\ … {}, {_route: “ojsxc.http_bind.index”})
  9. /var/www/wolke/lib/base.php line 1010
    OC\Route\Router->match("/apps/ojsxc/http-bind")
  10. /var/www/wolke/index.php line 37
    OC::handleRequest()

POST /wolke/index.php/apps/ojsxc/http-bind

I try to a couple of apps to deactivated and finally if i deactived Collabora Online, the speed increase inmeditly.
Just wunder why this app make me so much trouble with the speed of the website

3 Likes

Thanks for the hint I am also struggling with this issue since days
just for short term solution I disable the CO and the NC is started to work again

I hope somebody find the bug in the app or the platform soon to can use again the CO

Same Issue.
Fixed by disabling Collabora Online - Built-in CODE Server.

Thanks

1 Like

Problem solved for me too!
Thank you! :smiley: :+1: :clap: