RaspberryPI NextCloudPi Docker - Problem Loading Page

I’m trying to follow these steps to get a docker container running NextCloud on my RaspberryPI. The steps seem very straight forward except I can’t seem to get this working. The biggest difference is that I want to use an external drive as the data location. Here’s what’s happening:

I run sudo docker run -d -p 4442:4443 -p 442:443 -p 79:80 -v /mnt/nextclouddata:/data --name nextcloud ownyourbits/nextcloudpi-armhf

but when I go to https://pi_ip_address:442/activate (or any of the other ports), I get “problem loading page”. I’ve also tried using https://raspberrypi.local:442/activate as well as appending both the IP and the name to the end of the command (where the DOMAIN is listed in the instructions).

I’ve seen some posts talking about how this is a problem with how docker accesses mounted drives, but I can’t seem to get it working. When I type sudo docker logs -f nextcloud I get the following errors:

/run-parts.sh: line 47: /etc/services-enabled.d/010lamp: Permission denied
/run-parts.sh: line 47: /etc/services-enabled.d/020nextcloud: Permission denied
Init done

Does anyone have any steps to help get this working? I can’t seem to find a consistent/working answer.


On a raspberry pi there are better options to run nextcloud than a docker container (nextcloudpi), do u have a special reason to use docker as an additional layer of complexity?

My only reason is that I’m using the raspberry light for other reasons and when I looked up how to use NextCloud on a RaspberriPi, the consensus was to use an entire NextCloud image or Docker. I’m open to suggestions though; I’m not committed to using Docker if it adds complexity. I just figured it was easier than installing and setting up everything manually

I have installed nextcloudpi, moved database and datadir to the external hdd installed minidlna as a media server and so on, nextcloudpi is actually a headless raspbian so you can do whatever you want with it…

just to clarify, are you suggesting I install NextCloud image on my PI or install it on my existing Raspbian OS?

I did a fresh install with ncp image, but you could just install it using

# curl -sSL https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh | bash

This got me in the right direction. Thanks for your help!

If it was the solution, mark my asnswer as such, if not exactly, please write down what you did to solve your issue and mark that post as solution.