Raspberry Pi - 503 Service Unavailable

not yet, true. you need to order it directly. i myself am intersted in that one, as well. as for now the r64 pro is still beta. as far as i understood from it.

i myself am running a rpi3 and it’s running smooth with nc15. (even faster than at least nc 14, maybe even as nc 13).
so for small groups or family… and rpi3b+ maybe would do the job. and it defenitly wouldnt cost you a fortune.

you’re very welcome

1 Like

Today I got myself a rpi3 to, works well, setting up the harddrive at the moment, nextcloud is 1000x times greater when it works :grin:
I donatet some money as well, great community and definetly some money worth this good work…


[503 Service Unavailable] hits my NextCloudPi too, after manually upgrading operation. From ssh,

$ sudo ncp-report

show exactly the same:

“PHP service down”

Then I do:
$ sudo systemctl start php7.2-fpm

it works!
I have even done(maybe it is not necessary)

$ sudo apt-get install --reinstall php7.2 php7.2-cli php7.2-common libapache2-mod-php7.2 php7.2-mysql php7.2-fpm php7.2-curl php7.2-gd php7.2-bz2 php7.2-json php7.2-tidy php7.2-mbstring php-redis php-memcached

Wich model do you have (raspberry)
Because for php 7 a arm64 architecture is needed.

I use rpi 3B(2015).
Now Nextcloud is normal. NCP webpage shows as following:

System Info

NextCloudPi version v1.12.3
NextCloudPi image NextCloudPi_03-09-19
distribution Raspbian GNU/Linux 9 \n \l
automount no
USB devices none
datadir /var/www/nextcloud/data
data in SD yes
data filesystem ext2/ext3
data disk usage 2.8G/29G
rootfs usage 2.8G/29G
swapfile /var/swap
dbdir /var/lib/mysql
Nextcloud check ok
Nextcloud version
HTTPD service up
PHP service up
MariaDB service up
Redis service up
Postfix service up
internet check ok

Whilst I appreciate this is an old thread I just wanted to draw attention to reading logs fully.

@crustulumtheone posted logs on 2019 Feb 25th:

What does following mean (the error at Nextcloudcheck)

Running nc-info
Gathering information…
NextCloudPi version v1.8.4
NextCloudPi image NextCloudPi_01-14-19
distribution Raspbian GNU/Linux 9 \n \l
automount yes
USB devices sda
datadir (doesn’t exist) <- <- This will always generate errors in NC - NO DATA DIRECTORY!!
rootfs usage 1.9G/7.3G
swapfile /var/swap
dbdir /var/lib/mysql
Nextcloud check error
HTTPD service up
PHP service down
MariaDB service up
Redis service up
Postfix service down
internet check ok
port check 80 closed
port check 443 closed
IP ******************
gateway ********************
interface eth0
certificates none
NAT loopback no
uptime 7min

Hi @OliverV,

Please re-read my post…

I wasn’t asking a question, simply pointing out that an answer is very often possibly contained in the logs a user already has, and could be a cascade error (one leading to another).

@crustulumtheone had posted the logs initially, yet no-one thought to question why no datadir was configured, if the datadir was unconfigured, why not?

If this issued was resolved due to the issue you mention, then why was this not posted and accepted as the solution? Instead the marked solution is:

This not what you have supplied. Yet the above is what is marked as the solution. There is little to no point in not posting the confirmed solution for a poster. The OP should have been asked to correctly mark the solution that resolved their issue. Then finally edit the post title to ‘RESOLVED: xyz’ or ‘SOLVED: xyz’

This means anyone wanting to offer help doesn’t engage with an already resolved thread. Also those looking for help with similar problems can refer initially to threads similar to their issue, but that have been solved already.


yes. you found out something that might have passed others (including mine) attention. I really can’t remember anymore what crossed my mind back then.


apparently ncp wasn’t intended to run on a rpi1 anymore at that time. so why following some errors appearing when hardware is known to be problematic?

you complain that this thread was irregulary marked “solved” with no real solution. but wells… it IS a solution. and apparently it helped TS

so what did you really want to get out of your system? If you have a problem that needs to be solved please feel free to open a new thread (you even could connect it to this thread if you feel it might be a similar problem). don’t forget to give out as much information as possible about the problematic system(s).


Hi @JimmyKater,

You’ll notice my original replay states clearly

It wasn’t a reference to any subsequent resolution.

I ‘Do Not’ have any issue to resolve myself, so have no need to post a new thread.

Your later ncp explanation IMO is a far better solution than the marked one. It addresses the issue, is more detailed and informative. The marked solution doesn’t give any real detail as to why an RPI1 is ‘too old’. I don’t complain about the marked solution just draw attention to it possibly not being the best one.

I regularly read in the NC summary email newsletters about people who are frustrated with the forum and it’s responses / response times / answers. I come here from time to time to put a little back in to the NC environment. Far too often the same questions are asked again and again here, and often it’s due to insufficient detail in the question / response or simply not reading and digesting the information that was published.

Each time I visit though I seem to take longer to come back, as I feel a similar frustration with the forum community and a desire to offer a better resource for NC issues and NC community users.

Obviously everyone who takes the time and trouble to get involved should be, and is valued. BUt there is also nothing wrong in improving.

usually it’s up to TS to mark an answer being the solution. I dunno why this one was marked. But it initially solved the problem for TS. The one you’re referring to

is indeed more informative but is lacking for the main reason… “too old” But yes I see what you mean.

I’d like to get this thread here to your attention where some of this was already discussed

right… So thank you very much for your efford to improve the solution.


@all - i changed the solving answer according to discussion above.

1 Like