Raspberry Pi 4 SSD CMS samba transmission and others

Not sure if I’ll get any replies, but here goes.
I got myself a Pi4 (4gb) and a 1tb T5 SSD to replace the very old Pi I have.
The old Pi runs nextcloud (a very old version), as well as AlexaPi, Transmission, Traccar server and samba share of the nextcloud data to the network. It’s also using VNC so I can access the desktop from work (to bypass the odd blocked site like youtube) It all works kinda but slow.

So I decided to try and upgrade to the Pi4 and SSD.

First I attempted to boot from the usb, which initially failed (pro-tip: Don’t use noobs) eventually I got ‘buster’ Rasbian running great. Then I tried to install nextcloud, it worked but a lot of issues. I ignored those and tried to get the data directory shared via samba, total failure, best I can do is see the folder, not contents. After fighting for a while I downloaded NextcloudPi and flashed an SD card. It works, and shares the data via samba, however I can’t seem to install a CMS, never mind traccar, transmission etc. BTW transmission also uses the same data folder. I suspect I just changed all the permissions on the old pi so anyone could read/write/execute, not very clever but it worked for me.
Is there anyone out there who has done something similar, there are so many ‘guides’ on the net, it gets mighty confusing.