Rant about my frustration with NC

Re: nextcloud 18 snap:

I’m always having to re-do my installation of NC.
Collabora has never worked, and OnlyOffice + its community document server only work after a fresh install for a while and then it totally breaks. If I try to re-install the office features then the Document Server becomes a mess and I have to reinstall the whole NC, and that’s if I manage to pull up the apps pages.
The non-installed apps pages rarely ever show up and people have to apply some sort of technical fix, usually due to a timeout issue. And that’s even trying in both FireFox and Chrome, both remote and local.

NextCloud is awesome, and I really want it to become my anti-Google, pro-privacy solution, but it’ so darn frustrating!

The NextCloud 17 “stable” version is not a solution since only 18 and on have the features I really need.

If anyone has found a solution to these things, please let me know.

Hi, I strongly recommend installing Nextcloud with Docker and using something like Borg Backup or Rclone to keep it archive ready via Cron in case restores are needed.

I also recommend a “test instance” you can spin up just to use for upgrades before applying to your production system. For version updates, never apply until major bugs are squashed in the x.0.2 and x.0.1 maintenance releases.

Hope this helps a little, and others can chime in.

automation is everything.

Thank you both. Will check out your suggestions soon.
I’ve never used Docker before (knowingly). I’m just a Windows guy starting to use Linux.

Thanks Reiner. You clearly put in the effort to help others install this. It was even easier than installing something on Windows.

I used your Ansible playbook, and it’s worked like a charm so far. It wasn’t able to install Collabora or OnlyOffice, so I did it from within NextCloud.
No problems so far, but we’ll see.

I also don’t understand what to do with the final suggestion to recreate the dhparam.pem file. Do I simply type:
openssl dhparam -out /etc/ssl/certs/dhparam.pem 4096
sed -i s/#\include/\include/g /etc/nginx/nginx.conf
service nginx restart

I’m afraid if I start following those directions it’ll require me to get a Let’s Encrypt certificate, which I can’t because I don’t have a domain name.

*One last important question. What do I do if I restart the server? Will everything start back up automatically?

any error message? or you didn’t switch it on in the inventory.

btw: right now the branch “nextcloud-reloaded” of the “non-docker” playbook is “work in progress”. i have to change the way onlyoffice is installed. onlyoffice released a new version of the docker image and i have to remove a work around. nevertheless it should work. (use nginx as web server. apache/onlyoffice|collabora is not yet supported. work in progress.)

where did you get this suggestion?

no. i would be careful using sed -i s/#\include/\include/g /etc/nginx/nginx.conf . that just uncomments all # include lines.

no. that would work also with selfsigned certs. it’s just related to ssl. not to the certs.


Sorry for the late reply.

Re: auto install of Collabora or OnlyOffice, what happened is that it said it was going to download them, but the download failed. So I just used the app store in NC after the installation was completed.

The suggestion for the dhparampem was given at the last screen of the installation, where it said something like “For increased security, I recommend you also do this…”, so I used the link provided, translated the webpage with Google, and saw things like the 'sed -i s/#…etc etc.

Everything is still working well, and no problems at all.
Thanks again!