Question for mounting smb / cifs share on Synology NAS

Hi All,

currently i’m trying to mount a few smb / cifs shares from my Nextcloud which are located on my Synology NAS. A few days ago i installed an update on the NAS which deactivated smbv1. Due to the security issues with smbv1 i don’t want to reenable the version 1. Therefore i am looking for a solution how to mount smbv2 or v3 within my Nextcloud instance.

The instance is running in a docker-container from wonderfall (latest version). I already ssh-ed into the container and checked the php smbclient version which is 0.9.0.

Furthermore i applied the recommendation to set the smb protocol version min to smbv2 and smb max version to smbv3, which can be conveniently done via GUI on the NAS. On “regular” linux host systems this would be done vial smb.conf.

Unfortunately i am still not able to connect to any of my shares from my nextcloud instance.

Does anybody has an idea what i could try?

Thanks and regards,


just in case someone lands here, on NC 13 it’s still not working.

There shouldn’t be limitation from Nextcloud itself. In the past, there have been a few configuration issues: