Question about using php-fpm

I’ve been using PHP-FPM for my Nextcloud server on Apache2. I notice in the admin settings for Talk, it is warning under Recording Backend “The PHP settings “upload_max_filesize” or “post_max_size” only will allow to upload files up to 8 MiB”. However in the fpm php.ini file my settings are much higher. So my question: Is this page checking against the apache2 or cli php.ini files, and do all of these files need to be modified to match settings? I would have assumed I only need to make changes to the fpm php.ini file but I could be wrong. So if someone could help me understand that better that would be helpful. Thanks in advance!

Are you sure Apache is actually using PHP-FPM / FastCGI?

I used the following commands to enable it on my instance: (works on Debian and Ubuntu based systems)

PHPVERSION="8.2" #Change the version number to the version you're actualy using

a2dismod php$PHPVERSION mpm_prefork
a2enmod proxy_fcgi setenvif mpm_event
systemctl restart apache2
a2enconf php$PHPVERSION-fpm
systemctl restart apache2
systemctl restart php$PHPVERSION-fpm

Thanks. I had to switch to the mpm_event but forgot to restart php afterwards. I only restarted apache. Everything was already enabled, just forgot the restart.

1 Like

@bb77 So to answer my overarching question, you should only need to make changes to the fpm php.ini file, correct? The cli and apache2 php.ini files are not being used if fpm is enabled?

I’d say it’s probably enough to have it under fpm, but I’m not a 100% sure because I’m using the PHP config from here which has it in two php.ini files (cli and fpm)

Thank you for that resource! It also helped remind me to update the www.conf file as well otherwise Talk seems to bring my system to a halt with the default settings.

1 Like