QNAP Installation - 2 Queries - No Apps / Where To Place Data Directory


Totally new to Nextcloud and I think I’m missing something obvious if anyone could help out.

I’ve installed version 11.0.2 on my QNAP NAS [TVS-471] after installing qapache [2.4.25] and it all runs ok but when I select apps I have a list of only enabled or not enabled and there are no apps such as calendar, mail, tasks listed in either. I saw this topic:


and followed suggestion of editing config file to include ‘appstore.experimental.enabled’ => true, but doing that and restarting apache / nextcloud it hasn’t changed anything. My config file looks like this at present:

$CONFIG = array (
‘instanceid’ => ‘oc08syb0rars’,
‘passwordsalt’ => ‘xxxxxxxxxxxxxxxxxxxxxxxx’,
‘secret’ => ‘xxxxxxxxxxxxxxxxxxxxxx’,
‘trusted_domains’ =>
array (
0 => ‘xxxxxxxxxxxxxxxx’,
‘datadirectory’ => ‘/share/CACHEDEV1_DATA/.qpkg/NextCloud/nextcloud/data’,
‘overwrite.cli.url’ => ‘xxxxxxxxxxxxxxxxxxx’,
‘dbtype’ => ‘sqlite3’,
‘version’ => ‘’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘appstore.experimental.enabled’ =>true,

Secondly I receive these warnings on nextcloud. Where is suggested location for data directory on a NAS installation?

“Your data directory and your files are probably accessible from the Internet…”

“This server has no working Internet connection: Multiple endpoints could not be reached…”

Apologies for the double question!

Do you use libxml 2.7.0 or newer? If not, you shouldn’t run NC on QNAP:

Thanks for that. Although not really regarding what I was posting about but I have solved that problem myself.

However, you obviously feel this is important so could you please explain to a ludite like me why you must not run NC on a QNAP NAS? I don’t understand what is being implied regarding the importance of libxml 2.7.0? Is it a funcionality problem or a security problem?

Would be great to let other users know how you solved it.

I tried to read what exactly breaks, it seems to be related to the *DAV-protocols in general but I can’t tell you if you risk any data loss or if you have a security issue. It was however so important, that developers check that you don’t use libxml before version 2.7.0. Perhaps you are using your device with a newer version already. I would verify this.

It solved itself so to speak. It was simply a matter of the app page sometimes shows the list of categories and sometimes doesnt? I went back later and clicked and they appeared. Other times they don’t. As for the DB location I setup an new installation using mariadb rather than mysql lite and simply chose a different location at setup.

I must say i’ve been left with a very underwhelmed view of NC just through how shakey it all seems. Sometimes the login page does nothing and just asks me again to enter name and password. Sometimes the calendar app takes ages to display properly in the web page, syncing with my Fedora desktop through the app is a nightmare, just randomly closes the connection and god only knows how to get a secure SSL login to it. That just doesn’t work in the slightest no matter what I have tried. Perhaps its me, perhaps its the QNAP. Perhaps its the mysterious Libxml file. Just doesn’t seem real world reliable and ready which is a crying shame as it fitted the bill of what I wanted brilliantly. Looking at the amount of support and people using it I can only conclude i’ve sodded something up somehwere along the line.

Not sure exaclty if this is correct but searching the NAS I can see in usr/lib I have the file libxml2.so.2.9.2 - However I am really not up on things enough to know if that is being utilised.

Thanks for sharing this information.

I have very little problems and can’t share your experience at all. I had some issues in the past with the encryption app, now it’s becoming more and more stable with each version. With some calendar solutions (OS X, Thunderbird-lightening) sometimes the sync process stopped but not sure if this was related on the client or server (deleting and setting up the sync connection solved the issue). I have the impression that on plain server setups, it works pretty well straight away (more or less, optimization of your database and setting up a cache improves the speed a lot). Problematic are some administration interfaces, other closed source platforms where the configuration is hard to figure out, you have to stick with old incompatible versions, …

One more thing, here you have different demo versions how Nextcloud is supposed to work:

Thanks for the info. I’ll take a further look.

Its just got worse to be honest. I can no longer login in any way. If I use the web login firefox simply tells me the connection was reset. The desktop app drops the connection straight away and the phone app also fails. I tripled checked the NAS its installed on, all correct ports forwarded etc and its reaching NAS quickly, just seems NC itself timeout loading up?

Was a very simple straightforward vanilla installation with a couple of the apps added to have a look and get a feel for it. Not sure how to proceed now.