Push notification currently not available

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home users. If you’re running a business, get help on portal.nextcloud.com so we can make sure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Remember, the below information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Please delete everything above when creating your topic and provide the following:

Nextcloud version (eg, 12.0.2): 13.0.1
Operating system and version (eg, Ubuntu 17.04): OpenBSD 6.2
Apache or nginx version (eg, Apache 2.4.25): httpd
PHP version (eg, 7.1): 7.0

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Android Nextcloud app in notifications show Push notifications currently no available

The output of your Nextcloud log in Admin > Logging:

openssl_sign(): supplied key param cannot be coerced into a private key at /htdocs/nextcloud/apps/notifications/lib/Controller/PushController.php#117

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'oc0qzabn5g66',
  'passwordsalt' => '68ZuDX19+bfETFUrHfiGX6UL5iGsa+',
  'secret' => 'GRTSDjlA110bXO2Il0CqlA7k+a62rEDe2Z1HDN9qbeSdD2/d',
  'trusted_domains' =>
  array (
    0 => 'xxxxxxx.dyndns.org',
  'datadirectory' => '/nextcloud/data',
  'overwrite.cli.url' => 'https://xxxxxxx.dyndns.org/nextcloud',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'nextcloud',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_Alex',
  'dbpassword' => '3d7a1xKIRHJbqpTnPEECQItEpBlWEY',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,

The output of your Apache/nginx/system log in /var/log/____:

xxxxxxx.dyndns.org x.x.x.x - - [24/Mar/2018:21:51:52 +0000] "GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications?format=json HTTP/1.1" 200 0
xxxxxxx.dyndns.org x.x.x.x - - [24/Mar/2018:21:51:53 +0000] "GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications?format=json HTTP/1.1" 200 0
xxxxxxx.dyndns.org x.x.x.x - - [24/Mar/2018:21:51:54 +0000] "GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications HTTP/1.1" 200 0
xxxxxxx.dyndns.org x.x.x.x - - [24/Mar/2018:21:51:55 +0000] "GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications?format=json HTTP/1.1" 200 0
xxxxxx.dyndns.org x.x.x.x - - [24/Mar/2018:21:51:56 +0000] "GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications?format=json HTTP/1.1" 200 0
xxxxxxx.dyndns.org x.x.x.x - - [24/Mar/2018:21:51:58 +0000] "GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications?format=json HTTP/1.1" 200 0
xxxxxxx.dyndns.org x.x.x.x - - [24/Mar/2018:21:51:59 +0000] "GET /nextcloud/ocs/v2.php/apps/notifications/api/v2/notifications?format=json HTTP/1.1" 200 0
xxxxxxx.dyndns.org x.x.x.x - - [24/Mar/2018:21:51:59 +0000] "POST /nextcloud/index.php/apps/ojsxc/http-bind HTTP/1.1" 200 0

@nickvergessen any idea?

Did you check your /tmp directory permissions on the server?

Good morning, yes, I checked.
drwx ----- T 2 www www 512 Mar 25 10:21 tmp
sess_bqbhetnje789j5dbejph6342c4 sess_mjp76rn07iq1c1iffjf6fijtf5

thank you

Push notifications works well in the application of nextcloud windows and also works well in the chrome browser!

Just does not work on the android mobile phone showing in the application in notifications push notifications currently not available

I tried using https://demo.nextcloud.com/ and it works fine on my mobile phone

Thank you

Chrome and Nextcloud Windows don’t use the same kind of push notifications. Since push works with the demo server, your server is at fault so please check it out :slight_smile:

I have already reinstalled the server several times and still receive this message in admin logging
openssl_sign (): supplied key param can not be coerced into a private key at /htdocs/nextcloud/apps/notifications/lib/Controller/PushController.php#117

when I sign in to the nextcloud app on my phone

in nextcloud.log

{“reqId”: “O7V544szS8uF3TtmFmx3”, “level”: 3, “time”: “2018-03-26T14: 50: 37 + 00: 00”, “remoteAddr”: “x.x.x.x”, “user” Alex “,” app “:” PHP “,” method “:” POST “,” url “:” \ / nextcloud \ / ocs \ /v2.php \ / apps \ / notifications \ / api \ / v2 \ / push ? JSON format = & pushTokenHash = 7c159177c39dad28b0b2f1b536f851280424d3556b029abbb1f3db72455f648b35004712163fd96d9b20c681eff99d1440827c008f3fcc2bcc81287be453786d & devicePublicKey = ----- BEGIN 20PUBLIC%%% 0 ----- 20KEY AMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAneS6xCQs%2Fl50U1i6Exj%2F%0ATgyf6%2BLRjNXsdRjtbg0ICxLTSpnD7LhNAlNpWn4DJKDi0ZfMM4GGehLq%2BHM2Vr9B%0AoSuO%2BI%2FOzosDXCS8oJFamwomx8c%2BV81msT5tgQ49YMsn%2FKQFmNz0Fr4Jn6ozDGA6%0A%2FcHo08u8aencLhSJV4gc8xXqcbvluMqR%2B8tqme2MeK9MmqwDTNcd6CEL39Oe0 2Bge 0Aci9zidUBVI1yqvUSn8S4lkwnSKZF26UI3LT1uVA%%%% 2Bq7 2F6mWnwF5AWlpQT5xW3rDvo 0AkBy5oZYpvm%%% 2B3MWv7MZ20iiHuDIDRT 2FyzO05kY2ASUav04eQB7iPvy5sQszfg1Avp 0AzwIDAQAB%%% 0A END ----- ----- 20PUBLIC% 20KEY% 0A & ProxyServer = https% 3A% 2F% 2Fpush-notifications.nextcloud.com " , “message”: "openssl_sign (): supplied key for m “,” userAgent “:” Mozilla \ /5.0 (Android) ownCloud- “” Mozilla \ /5.0 (Android) ownCloud- android \ /3.1.0 RC1 “,” version “:” "}

I do not know what to do anymore

some help please

I installed linux (elementary os) instead of OpenBSD and installed nextcloud!
Now the notifications in android works fine without any changes in the config.php or settings!!
(elementary os) uses apache and OpenBSD uses httpd

Has anyone been able to use the nextcloud in OpenBSD and have the notifications on the android working ??

If so, will it be possible to explain how you got it?

I think it should be some configuration in httpd.conf that I’m not seeing

this is my httpd.conf configuration

A minimal default server

server “xxxxx.dyndns.org” {
listen on $ext_addr port 80
listen on $ext_addr tls port 443
tls {
key "/etc/ssl/private/xxxxxx.key"
certificate “/etc/ssl/xxxxxx.fullchain.pem”
# Set max upload size to 2Gbytes (in bytes)
connection max request body 2147483648
hsts max-age 15552000
directory { index “index.php” }
location “/.php” { fastcgi socket “/run/php-fpm.sock” }
location “/.well-known/acme-challenge/*” {
root "/acme"
root strip 2

Anyone with OpenBSD ??
Thank you.