Public upload is broken when quota_include_external_storage set to true

If i set
'quota_include_external_storage' => true
in the …/nextcloud/config/config.php
the quota for a user will be displayed correctly but uploading files via a public share will fail.

How to reproduce:

  1. Set ‘quota_include_external_storage’ => true
  2. Open a public share and try to upload one or more files using Edge or Firefox (e.g. v.48)
  3. any public upload will fail, the spinning wheel never disappears

If i set
'quota_include_external_storage' => false,
the qouta will be miscalculated and an errormessage appears
Your storage is almost full (98%)
But the public upload will succeed.

I already raised an issue on github:


Does anyone have the same issue?
Cheers, Carsten

Yes, and false fixes the issue – w/o wrong quota calculation. (I have local external storage only!)

OK, thanks for your yery quick response!

Do you mount data from nas to your cloud either?

Caused by the very limited physical storage on my odroid c2 (eMMC 32GB) i mounted my nas share.
The total amount of declared storage is about 1.5 TB and round about 643 GB are in use.
Mount a NAS-share and set the config-parameter to false leads nextcloud to miscalculate the quota => "…Storage 98% full…"

Do you or anyone else have a similar constellation?
Cheers, Carsten

No, the external storage is a partition on the same server, outside Nextcloud.

Which quota has the user with the public uploads? (Unlimited or Default? Default = Unlimited?)

The quota is set to ‘1.5 TB’.
If the qouta would be set to ‘unlimited’, the message “…your storage is almost full …” is shown in the file app and personal panel again.
This happens on 32Bit as well on 64Bit OS (ubuntu)

enable_functions = disk_free_space, disk_total_space in php.ini may solve this problem.

currently both options are not disabled.

disable_functions = pcntl_alarm,pcntl_fork,pcntl_waitpid,pcntl_wait,pcntl_wifexited,pcntl_wifstopped,pcntl_wifsignaled,pcntl_wifcontinued,pcntl_wexitstatus,pcntl_wtermsig,pcntl_wstopsig,pcntl_signal,pcntl_signal_dispatch,pcntl_get_last_error,pcntl_strerror,pcntl_sigprocmask,pcntl_sigwaitinfo,pcntl_sigtimedwait,pcntl_exec,pcntl_getpriority,pcntl_setpriority,

could you please explain in detail where to enable? should i paste it below the disable_function in the /etc/php/7.0/fpm/php.ini or in nextcloud’s .user.ini-file … ?

— i tried out —
I did modifications to the .user.ini, the php.ini and set ‘quota_include_external_storage’ => false. Unfortunately still the same behaviour, even after restart php and nginx.

As I wrote above:

enable_functions = disk_free_space, disk_total_space

in php.ini fixed my problem but I don’t have mounted really external storage.