Public file share: Bypasses download page, shows Nextcloud Online

Nextcloud version (eg, 20.0.5): 26.0.1
Operating system and version (eg, Ubuntu 20.04): Ubuntu Server 22.04 LTS
Apache or nginx version (eg, Apache 2.4.25): 2.4.52
PHP version (eg, 7.4): 8.1.2
Is this the first time you’ve seen this error? (Y/N): yes

The issue you are facing:
My public share links now redirect from the download page to Nextcloud Office, which I’m not that interested in. I see the download page for a brief, then it changes to the Office viewer / download page.

It’s very possible I may have changed a setting somewhere that I wasn’t aware of what meant, so if anyone can help me restore a direct download link, I’d be very grateful.

(Yes, I know you can go back one step you end up at the download page, and that it has a Direct download link, but this is not doable for me as I have a lot of shared files).

The user I’m sharing from is a standard non-admin user.

My Nextcloud Office admin settings page:

  • “You have not configured the allow-list for WOPI-requests…”
  • “Collabora Online server is reachable”
  • "Use the built-in CODE … " is selected

I looked at the documentation, but it didn’t help me much. Don’t know if I missed something here?

Thanks in advance!

You can add “/download” to the share url.


Thanks for your reply:

Yes, it works but I have a lot of shared links that are already up, so manually adding something to a link and then checking that the link works as intended, is an extra task I’d rather do without. I would also have to repeat that task for all future links that I share.

It used to be that I could copy a direct download link from the Share panel, which is what I’d like to regain if at all possible.

I’m pretty sure there should be a setting somewhere, but the documentation doesn’t say anything.

Unless there’s a better solution in a few days, I’ll mark your reply as the correct answer.

Thanks again!

1 Like

I think there is no other solution. By default, a file is displayed for a share. I don’t think that can be changed. Maybe you can change something with .htaccess (rewrite). But that would then apply to all shares.

I removed the Office Online integration, which I don’t need anyway, since I’m heavily dependent on Microsoft Office.

Now, the share link opens up a download page and in the top right corner, there’s a direct download link under the ellipsis:

You can add /download to the share to get direct the download link.