Proxy exception required

#1

Sorry to hear you’re facing problems :slight_frown:

If you’re urgently looking for support to keep your business running, consider checking out our paid support options.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the following as you can (you can cut and paste this into your topic):


Nextcloud version (eg, 10.0.2):
Operating system and version (eg, Ubuntu 16.04):
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 5.6):
Is this the first time you’ve seen this error?:

Can you reliably replicate it? (If so, please outline steps):

The issue you are facing:

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:


Remember, this information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.

#2

Hi sorry for the mess of this message but i’m new and i’m learning how to write in this community, I have an issue using nextcloud behind a proxy for the internet connectivity.

The problem is this, to make nextcloud be able to download app, search for update etc I have insert into /var/www/html/nextcloud/config/config.php the ‘proxy=> XXXXXXXXX’ statement and it made the work.

Now I have installed collabora and I have to comment the proxy statement to avoid my nextcloud to send the traffic to collabora troughout the proxy server (and in this case don’t work).

As workaround now i activate the proxy setting in maintenance windows but I would like to kwon if there is some better way to fix the problem.

Thanks a lot

#3

Maybe someone else has a better idea, but as far as I know you can redirect connections with iptables. I don’t know how, as I’m not an iptables expert and I would need to consult the docs but just wanted to mention it.

#4

Hi !

Did someone found a solution to this problem ?
I’m also faced to this situation with my both server (nextcloud & collabora) in the same network, behind a HTTP(S) proxy. I cannot choose to switch between enable/disable proxy from the config.php file.