"PROTOCOL_ERROR" when trying to connect to the server by server's local network IP

I’ve spent all day setting up Nextcloud AIO on an old PC running Debian 12.
I got it working - kind of. I can access nextcloud from nextcloud.domain.org (example address) when not in the local network that the server is connected to.

So, when trying to connect to that domain from my own local network, it does not work as my router does not allow that. I thought, that it’s no big deal as I can just open my server’s local network address and access nextcloud that way, but when I try that, no matter the browser, I get an error - “SSL_ERROR_INTERNAL_ERROR_ALERT” on firefox, and “ERR_SSL_PROTOCOL_ERROR” on chromium.

What could be causing that?

Hi, see GitHub - nextcloud/all-in-one: The official Nextcloud installation method. Provides easy deployment and maintenance with most features included in this one Nextcloud instance.

I just noticed something different with the server - I can actually access the nextcloud.domain.org domain on different devices in the network - the thing is, I cannot access it from my desktop computer, I tried both by an ethernet cable and a wifi card, nothing is working. What could cause this? By the way, the site can be pinged from the terminal on my computer.

Your router. Thus the recommendation for a local dns server…

nope, it turns out that I had some random lines in the hosts file on my desktop pc related to my public ip and the domain, thus it could never load the domain.

1 Like

Hi,

ist is solved, perfect. Just to understand. Is there a cert for your private IP?

thx
sambilanet

wdym by “cert for private ip”?

Do you have a workin and valid https connection to your local Nextcloud IPs or name ?

yes, i do have a working and valid https connection

1 Like

Thx! Good Luck.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.