Problems with memcached

I have installed memcached on my vserver according to this instructions.

After the installation I’ve added this lines in my config.php:
‘memcache.local’ => ‘\OC\Memcache\Memcached’,
‘memcache.distributed’ => ‘\OC\Memcache\Memcached’,
‘memcached_servers’ => array(
array(‘localhost’, 11211),
),

I have no security warning in the admin area. But I’ve got a PHP error:
PHP Startup: Unable to load dynamic library ‘/opt/plesk/php/7.1/lib/php/modules/memcache.so’ - /opt/plesk/php/7.1/lib/php/modules/memcache.so: cannot open shared object file: No such file or directory at Unknown#0

The system is looking for a memcache.so file but I have installed memcached. That means I have a memcached.so file. Is this a Nextcloud issue or something on my vserver?


Nextcloud version: 12.0.2
Operating system and version: 16.04.3 LTS‬
Panel: Plesk Onyx 17.5.3
PHP version: 7.1.9

I just recently went through this on my install. Its a php issue on the server. Only difference is mine is in a bsd jail on a freenas server. To get memcache.local, you need APCu. ‘memcache.local’ => ‘\OC\Memcache\APCu’

I installed from bsd ports. pecl-APCu

Here is a page in the nextcloud admin guide which explains a lot of this.

https://docs.nextcloud.com/server/12/admin_manual/configuration_server/caching_configuration.html

Are you using Plesk? I’ve read that installing APCu in compination with Plesk and PHP 7 is not recommended / produces problems.

[edit]
To be honest - I do not get it. Memcached is already installed. Why do I need APCu?

Has someone an idea? Memcached is installed but still a PHP error.

memcached.so’ isn’t the same thing as ‘memcache.so’ and both are different than APCu (from what I read in the nextcloud documentation anyway)

According to the documentation that I linked in an earlier post APCu is required for memcache.local (I could be mistaken though, but that is how I understood it when I read through it)

I have seen where others have posted online (https://ramsdenj.com/2017/06/05/nextcloud-in-a-jail-on-freebsd.html#database) that they used redis for memcache.local…but I wasn’t able to make this work mysefl.

https://docs.nextcloud.com/server/12/admin_manual/configuration_server/caching_configuration.html

I know. And this is the reason why I am confused because I have installed memcached and the system is looking for a memcache.so file.

Thank you for your help but FreeBSD is no option. I run an Ubuntu server. I’ll keep looking for a solution. Maybe APCu or Redis is a possibility.

I have found the mistake. In the folder /opt/plesk/php/7.1/etc/php.d/ was a memcache.ini file and this was wrong. I deleted the file and added memcached modul again:

ls -la /opt/plesk/php/7.1/lib/php/modules/
echo “extension=memcached.so” >/opt/plesk/php/7.1/etc/php.d/memcached.ini
/usr/local/psa/bin/php_handler --reread
service plesk-php71-fpm restart

thank you that the tipp i missed

had a look at this place i found that memcached.so has wrong file-rights.
in nextcloud config only add localhost, not the domain, then its working for me
14.0.3 finished!