Problems with integrity check after upgrading to 15.0.0 RC3

Hello guys, this is my first post here and I hope you can help me.

Today I’ve upgraded my Nextcloud manually from 15.0.0 beta2 to 15.0.0 RC3.

Nextcloud is on my Synology,

I’M using PHP Version 7.0.30

I followed every step from this manual:

After the installation I checked the security warnings in Nextcloud.

I was told that http headers were missing, so I made additions in my .htaccess.

And I copied my old config.php to the new config folder.

Now I get problems during integrity scan:


  • core
      • .htaccess
      • config.php

I don’t understand these problems.

In the old versions it was no problem to alter the .htaccess, and why is config.php an extra file?

I know that I can disable integrity scan but I would love to understand why the errors happen and how I can get rid of them without disabling the scan.

Thanks for your help.

So the problem with config.php I solved myself.

The file was copied to the nextcloud folder instead of the nextcloud/config/ folder. After deleting it, this error disappeared.
Now there is the problem with the wrong hash value. I tried to undo my changes but it seems that the hash is still wrong.

I’ve tried to resync my .htaccess with the command:
sudo -u http php occ maintenance:update:htaccess
The bash said OK but still the same hash problem

I believe there was a “rescan” button for the integrity scan. Did you try to click that again?

I had this issue with RC2 by the way, but it didn’t re-occur with RC3. Strange that it happened to you with RC3. I’m wondering where this is coming from.

Hi Schmu,
yes I tried the rescan button.
But no success.

While I’m not sure about possible root causes, I can only suggest to download the zip archive of NC15 RC3 again, extract the .htaccess file again to the nextcloud folder and hope it helps. Hit the rescan afterwards again of course.


I was exactly trying this while your message popped up.

This eliminated the error. I think I know why this happened. If you change anything within .htaccess you have to insert it at the end not within the settings. There is a warning within .htaccess that you should not change anything above that line.

I’ll give it another try.

Oh I see. Makes sense :smiley:
I’m using nginx so actually never touch the .htaccess. That’s why I found it very strange it happened to me. Thought it happened to you as well without any changes to that file.

Fingers crossed your changes work now, when put below the line :slight_smile:

Well, my Synology also works with nginx, but I installed a VHOST for nextcloud that runs apache.
I don’t remeber why this was installed this way but I know I’ve followed some manual on this.
So I sometimes do security changes in nginx moustache and in .htaccess
Maybe I should figure out what is best for my settings!?

I’ve checked my old .htaccess and the new one with diff to see what changes I made in the old one.
The warning with DON’T CHANGE ANYTHING ABOVE THIS LINE was in the old one.
I replaced my .htaccess with the original one to get rid of the warning. After that I altered it once again and did an integrity:check-core and no problems anymore.

1 Like