Problems with encryption in 11.1

Debian Jesse
Nextcloud 11.1

I enabled the encryption in the admin settings, loaded the app, logout/login a new user, but now I get an error every minute in the logging section of the control panel:

Encryption module "" not found, file will be stored unencrypted (Default encryption module not loaded)

  • I have confirmed the app is enabled in the Apps section.
  • I have confirmed files are being encrypted (made a text file in the NC browser, tried to view it via command line)

Ideas where to troubleshoot?

Update: Here is the full output from the nextcloud.log file:

{"reqId":"zBCt8E8UszYWNkynMgWY","remoteAddr":"X.X.X.X","app":"no app in context",
"message": "Encryption module \"\" not found, file will be stored unencrypted (Default 
encryption module not loaded)","level":2,"time":"2017-02-11T19:40:14+00:00","method"

x.x.x.x is my current home IP address where I am browsing from (not the server)
I also just added a federated cloud share with another test install of NC 11.1:

  • that share was notified in the browser (“New incoming share”)
  • I clicked “Accept”
  • then the spam of errors started hitting the log file
  • no share ever showed up, the “Shared with you” tab does nothing (not even a loading animation, just blank)

Both servers have home folder encryption enabled and working.

OK, one last Update:
I removed the federated shares and the log error entries stopped immediately.

I am not sure if I should close this topic and open a new one on federated shares issues or keep it here since the errors do reference missing encryption modules (which do exist and function correctly on both NC servers).


More updates:

I removed the “Home folder Encryption” option, verified new files get stored unencrypted, tried new federated shares but the problem persists (log file hammered with errors, no shares actually work).
So I am assuming this problem is with the Encryption module (not the federated sharing). The only way I can prove this theory is to do complete re-installs of both servers, refrain from enabling the encryption at all, and try again. :sweat:

Unless someone can confirm that 11.1 can handle federated shares (could save me some time). Tx

I found 2 similar threads on this issue:

UPDATE: Theory is correct! Federated sharing works correctly in fresh 11.1 installs. Gotta be in the encryption module.
Unless this is a known bug that will be fixed shortly, maybe we should request a warning added to the existing warning when enabling local encryption explaining Federated Sharing will be broken.

Today I noticed the same errors as a problem was pointed out by one of my nextcloud users.
I remember federated shares worked without a problem on encrypted files prior nextcloud 11.

Now after some initial tests i see that:

  • when adding a share from public link files do not apear and server gives exactly the error you specified.
  • when sharing with someone on the same server but using their federated share id same thing happens
  • when sharing from non-encrypted nc instance over to encrypted one via federation - same thing happens (on encrypted one)
  • sharing directly with users on the same server works ok.

Apparently you can see the directories in the mobile browser (but I haven’t tested it out myself).

Everything works without problem on android mobile client. I can see federated shares and access them with no problem. @tflidd is this known issue? shall I make a bug report on github?

I’m not using the encryption module, so I don’t know about current issues. Check out on github if you can find such an issue. If you two ran into the same issue independently, a bug is not unlikely.

Can confirm issue with two encrypted next cloud instances when sharing via federation.

Shared files are visible via the Android app.