Problems with config.php

Hi together,

when trying to install the password-manager passman app to my nextcloud i wanted to create a webcron to my nextcloud (does not run with AJAX). Therefore i tried to enter a trusted domain to my config.php because there was a error when trying to access the cron on ‘’ when the installation is on ‘’.

I have a nextcloud installation on a Webspace at

I tried to edit the config.php then by ftp. But the ftp client wasn’t able to overwrite the config.php. Finaly i deleted the old one and tried it again. (Of course i backed up the old one before).
Nextcloud generated a new config.php by it self and the “new installation” dialog appeared when i went to the homepage.

I found out, that i can edit the config.php when setting the “file-owner” to ftp-siteadmin-user with my ftp account in the webspace (threw the webspace admin web-UI). But just after reset that “file-owner” to “webservice-user” nextcloud once again overwrites the config.php.

Sure it is obvious what is the mistake i do. But i’m unfortunately not an expert on that and don’t know how to solve that problem.

Thanks for help.

Some apps don’t work with webcron, but currently i don’t have in my mind which one.

I recommend to use cron

but that requires a ssh account (which i can recommend too)

I know, that it would be best to have a root server for that. But in fact i do not have.
Finally that does not bring back my Nextcloud in the current situatuion :frowning:

Well, i would install it again in that case.

First, never remove the config.php, as you can see it completely loses connection to old instance, so that without careful steps all old Nextcloud data is lost/not connected to current instance anymore.

All files within the nextcloud directory need to stay owned by webserver user, e.g. www-data
If you want to allow access for other software/users, e.g. FTP, add the related user to the webserver user group, e.g.
usermod -a -G www-data ftp-siteadmin-user