Problems with APCu

Hello to all,
sorry if I ask a trivial question and newbie. I’m having trouble with my Raspberry Pi 2 Model B, php7.2, mariadb, apache, ubuntu 18.04 for Rapsberry.
I had to install all over again, everything works fine except memcache.
I did so:

  • sudo apt install php-apcu redis-server php-redis
  • sudo service apache2 restart
  • sudo nano /etc/redis/redis.conf and I put “port 0” and “unixsocketperm 770”
  • sudo usermod -a -G redis www-data
  • sudo service apache2 restart
  • sudo service redis-server start
  • I have configured the Nextcloud config.ini as follows:

‘memcache.local’ => ‘\ OC \ Memcache \ APCu’,
‘memcache.locking’ => ‘\ OC \ Memcache \ Redis’,
‘filelocking.enabled’ => ‘true’,
‘redis’ =>
array (
‘host’ => ‘/var/run/redis/redis.sock’,
‘port’ => 0,
‘timeout’ => 0.0,

  • sudo systemctl enable redis-server

I can safely enter my Nextcloud both locally and remotely, but I can not upload files or create a folder.
Why? Where am I wrong?

There should be no spaces between \ and OC as well as the rest. It should be \OC\Memcache\APCu
The same goes for the rest of the settings as well.

and thank you very much for your reply! :slight_smile:
I do not know why but in fact I had put two of “” before and after OC, I realize only now that they are not seen.
However even with only one, unfortunately I always have the same problem… :frowning:

This is my config:

'memcache.distributed' => '\\OC\\Memcache\\Redis', 
'memcache.locking' => '\\OC\\Memcache\\Redis', 
'memcache.local' => '\\OC\\Memcache\\APCu',


Which is the same as what I put… but it keeps giving me the same problem… :frowning:
Thank you so much, if other ideas come to mind, I’m here! :slight_smile:

This has single slashes, not doubles like in my example?

Yes I know, and in fact I have put two. But I do not know why only one appears, here on the forum.