Problems with accessing nextcloud through dns

Nextcloud version
Operating system and version armbian 22.01.1 (debian buster 10)
PHP version 7.4

I am having problems with accessing my nextcloud instance through the dns. So everything worked until a week ago, i didn’t change anything that’s the weird thing, suddenly i couldn’t access my nextcloud anymore, it says unable to connect, so firstly i suspected dns, i have it registered at noip so i checked if it’s still active and it is, also pinged it and it worked. Then i suspected ssl certificate so i checked and it’s valid until july so that’s ok, so at the time i am accessing it through local address without the dns, just type the ip in browser and it works so that means that nextcloud is working normally and the problem is somewhere else, any idea what could be the problem?


There are 2 IPs involved here.

  1. You “local” IP as you have referred is the most likely the LAN IP given by your router
  2. Second IP is WAN IP given by your ISP, this public IP is used for accessing the setup from internet via your NoIP DDNS Setup.

Now there are two type of WAN IP,

  1. CG-NAT
  2. Direct Public IP

DDNS or internet access from outsite will only work if your ISP has assigned your router a direct Public IP. However some ISPs use CG-NAT setup, where one of their Public IP is shared via CG-NAT to multiple end users and users are assigned CG-NAT (Internal) WAN IP to their routers.

So first check if your router has a direct public IP or CG-NAT.

If may check the router WAN / Internet Connection status / details → Note down the IP there, then visit google and search “what is my ip” → that will show the public IP. Now match if they are same or different?